Cantabile 4 freezes

Good morning to the whole forum,
I have installed Cantabile Lite Version 4,
one on an old laptop on which it works great without hitching … (OS Windows 7)
while on the fixed PC always with Win 7 OS, when I open Cantabile it is not possible to change anything it does not allow you to open the MIDI Audio Setting, because it slows down everything saying that Cantabile does not Respond and forces me to terminate the application, I would like to try to reinstall Cantabile, do you think this could be a solution?
Before On this PC version 3 was installed and it worked fine, but it was not possible to see the VST3, so I installed version 4 which sees the VST3 but it does not work well because it does not allow you to set it correctly …
anyone have any ideas?

I’d suggest re-installing Audio and MIDI drivers - looks like something is wrong there…

Hi Thanks for the reply,
it is evident that something is wrong,
but even before you can put your hand to the drivers the program blocks everything even just to add a VST,
so I immediately tried to make it work with the drivers of the integrated windows sound card and already here it is a problem, in addition I noticed that both on the laptop and on the desktop I can not get the pc keyboard to work to listen to the VSTs without of its own keyboard while on version 3 it was enough to select onscreen keyboard, I would be inclined to go back to version 3 of Cantabile, but I would need it if there is a version 3 that reads the VST3s, the one I had installed before did not see them, and this is the reason for which I switched to version 4, does anyone know for sure which version 3 reads and runs both VST2 and VST3?
Thanks for your attention!

Hi @ChanteChat,

Cantabile version 3 is surely able to load VST3 plugins. I suspect something was wrong with your setup. VST3 plugins are usually installed in
C:\Program Files\Common Files\VST3
(at least this is the default location).
You have to configure Cantabile to look into that folder. Check that this folder is listed in
Tools->Options->Plugin Options
as explained here

I guess the reason why Cantabile4 is able to see VST3’s right from the start is that the default VST3 folder is already listed there by default, but I am not 100% sure about it.

Cheers,
Gabriel

Torsten was probably suggesting to reinstall the audio and midi drivers on your fixed PC with Win7 even before launching Cantabile.

There are also a few debug options:

  1. select the “null audio” driver in Tools->Options->Audio Engine and check if Cantabile freezes anyway; if it happens again, then it has nothing to do with audio drivers.

  2. have a look at the log file which is located in a folder which you can access with
    Tools->Open Settings Folder
    In that folder you will find the last and second to last log files (they are ordinary text files). If you are lucky, at the end of the log file you can find some hint about the reason for the freeze out.

  3. as you said, deinstall Cantabile4 and reinstall it from scratch

Hope this helps,

Gabriel

Hi. Not if that helps. For using the PC keyboard: Initially, when I switched to C4, the PC keyboard did not work. I checked the options and found that the default Main Keyboard was missing. I re-downloaded C4 and it reverted to this default. On another occasion, to make the PC keyboard work I put the flags in the options also on Onscreen Keyboard (they were missing). They are attempts to figure out if it is a Flag problem. Another solution can be to copy the 3 .JSON registro files from C3 and paste it into C4. Try these alternatives.
Sergio

In the previous version 3 everything was set correctly even the VST3s were installed in the right Directory, nevertheless cantabile did not see the VST3 folder even though he had made him look for it in the reference folder … just did not read them!
then installed version 4 and the program automatically loaded the VST3, so the problem was not my wrong configuration but just cantabile 3 that had some problems …

thank you very much for the help

Hi Thanks, the keyboard problem on the PC I solved, it was a question of configuration and of putting the flag on the onscreen keyboard …
normally this configuration is automatic, but in this case it had to be redone …

1 Like

Ok, I understand.
I have seen this happen when the VST3 version does not match the Cantabile version. For instance, if 32bit VST3 are installed and Cantabile 64bit is launched or viceversa.
Make sure that the VSTs and Cantabile are both 32bit or both 64bit (unless you have installed jbridge to load 32bit plugins in a 64bit Cantabile version).

Gabriel

Gabriel, @ChanteChat,

as far I know, Jbridge won’t work with vst3. Only vst2 (up to 2.4) is supported.

You’re right, @cpaolo. I had forgotten about it.
Edited: this means that VST3 with the wrong bit “flavour” simply won’t load in Cantabile.
Gabriel