Cantabile 3 Lite Bindings and midi not showing/routing


#1

Hi,

I’ve been using Cantabile lite for almost a year without any problems because I was only using it to host VSTs for voicemeeter asio. I was already using my midi controller to control voicemeeter so it wasn’t useful to use it with cantabile since it doesn’t have enough memory to be used on both cantabile and voicemeeter.

As I now was able to config correctly Bome MT Pro to work with everything I needed midi for, I still can’t make it work with Cantabile and my VSTs. I don’t even have the “Bindings” tab and cantabile doesn’t detect MIDI input from the Bome’s MIDI input I’ve setuped which is very frustrating cause it works evereywhere except on cantabile.

Is it because I’m using Lite or is it just me that didn’t setuped Bome correctly and that Cantabile is not compatible with it?


#2

Hi Yukana,

Not sure on the Bome configuration but on the bindings tab question it is because Lite version does not support bindings.

Cheers,

Dave


#3

Hi Nepmia,

Bome uses virtual MIDI ports to get in and out of its interactions. Cantabile, under the options, allows you to set up input and output MIDI. Somewhere in there, to get to Bome you’ll have to access the virtual MIDI ports. Are you following? Can you see the virtual MIDI ports in C3?


#4

the bindings tab question it is because Lite version does not support bindings.

It’s what I was thinking, thanks for telling me, it means I may need to upgrade.

Bome uses virtual MIDI ports to get in and out of its interactions. Cantabile, under the options, allows you to set up input and output MIDI. Somewhere in there, to get to Bome you’ll have to access the virtual MIDI ports. Are you following? Can you see the virtual MIDI ports in C3?

I did made an in and out ports for Bome’s MT

And it didn’t seemed to quote any virtual ports…


#5

You’ve got that right. In Cantabile you should be able to have a VST listen on MIDI in and play out on an audio port. Those Bome ports are virtual because they aren’t connected to real hardware devices.


#6

That’s the thing, it should work but it doesn’t, log window doesn’t even log when I press keys and cantabile doesn’t detect anything from the bome input.


#7

Hmm, here’s what I just did:

  • Installed Bome MT Pro trial
  • set up a quick translation that sends a MIDI note when I hit the “t”-key on my PC keyboard
  • connected that translation to the Bome Virtual Midi Out port

Now whenever I hit the “t” key, this translation triggers and Bome sends out a MIDI note (visible in the Bome event monitor). So far so good :wink:

Now, I connected the Bome Virtual Port to my “Main Keyboard” Midi Input in Cantabile’s MIDI I/O settings, then opened a MIDI Monitor on that input port and hit a few “t”'s:

Et voilà - all the note on events created by hitting t’s appear nicely in Cantabile’s input.

So it seems that a connection between Bome MT and Cantabile is possible and working using the Bome virtual MIDI ports.

What you can do:

  • check in the event monitor panel of Bome MT that it is actually sending out MIDI events (is the “MIDI Out” LED blinking?)

  • check that you have actually connected your Bome MT translator items to the correct MIDI port and not to a different MIDI port (e.g. to a physical port and not the virtual MIDI port). If Bome is sending the MIDI messages to a different destination, Cantabile won’t be able to see them…

  • you can use a MIDI diagnostic tool like MIDI Ox to check if those MIDI messages can be seen there on your virtual MIDI port (just to take Cantabile out of the equation)

Cheers,

Torsten


#8

Thanks for that detailed reponse! Translating and all wasn’t the problem, the led is blinking correctly, I think it was the MIDI port I used, it was the virtual one but I had only enabled Virtual Out, which may be the problem, after enabling the In port Cantabile detected my notes!

So thanks to you all for helping me :slight_smile: