Cannot start cantabile

bug
Tags: #<Tag:0x00007fb8283758d8>

#1

Hi everyone
I was trying cantabile for the first time, after viewing some video on youtube

But I immediatly encountered some problem: after installing the software, when I try to run it, Cantabile is stuck on the starting screen (after selecting the license (Lite)). If I shut it down from task manager, the next time I can disable a lot of features (dont’ start the audio engine, don’t reaload the last song, don’t scan plugin folders, don’t reaload any settings, disable GPU accelerated rendering. The only way to reach the main window of Cantabile is checking every thing and, again, after selecting the license type, selecting CANCEL instead of continue. But the program is unusable, as soon as I click on anything it freezes (Cantabile not responding in task manager), There is also one more thing: log.txt and log-previous.txt are both empty (0 byte)

Thanks for any suggestion


#2

Hi Michele and Welcome!

I’m not sure what’s up but it might be that a firewall is blocking Cantabile from accessing the licensing server. By the way, what version number are you using and what is your Computer setup in brief form and post a screenshot of the window where you get stalled at.

Thanks,

Dave


#3

Hi thanks dave

I already checked my firewall, and the application has full access to internet (sorry, i forgot to mention it in the previous post).Il also tried to completely shut down the firewall (I’m using Norton Security instead of windows firewall)

My PC
OS: Windws 10 x64 Professional (last update last wednesday)
MB: ASUS Rog Strix z390-F Gaming
CPU: Intel core i7-8700
Ram: 32GB (i don’t remember the exact model, but I don’t think it’s crucial)
Hard Drive: 256 SSD Samsung EVO 970
Sound Card: Asus Xonar Phoebus
GPU: NVIDIA GeForxe GTX1060

Attached 3 images

3.png: where the program hang (or at least Task Manager report the program in “not responding state”. I tried to wait for more than 60 minutes in case someone was giving problem)


#4

Hi Michele,

Thanks for the pic, I will flag this post for @brad the developer and see if he can get your situation sorted, you have done it all correctly from what I see so I can’t offer any explanation for this behavior. I think he will probably chime in sometime in the next day or so.

Best,

Dave


#5

Have you tried running Cantabile as Admin? Maybe a file permissions thing? Cantabile wants to write in \Users-your name-\AppData\Local\Topten Software*


#6

Hi Michele

I been involved in IT for many years. I can’t tell how many times we’ve uninstalled Norton security products and then been able to run a program that was balking previously. Not saying that is your issue, just sharing experience. More likely the problem is the audio driver. Try ASIO4ALL - I estimate you’re the first person running Cantabile with the Xonar Phoebus. It could be an issue with it’s drivers.


#7

Hi @doGmaI,

Thanks for reporting this… sorry you’ve hit this problem. Not sure what it might be off hand. I’d be interested to see a log file.

If you can get into options, then go to Options -> Diagnostics and turn on “Log File Write Through” first. If not, don’t worry about it, then:

  1. Start Cantabile and reproduce the problem.
  2. Kill Cantabile in task manager
  3. In Window File Explorer, go to the folder C:\Users\YOURUSERNAME\AppData\Local\Topten Software\Cantabile 3.0 (x64)
  4. Send me a copy (brad@cantabilesoftware.com) of any files in that folder and I’ll take a look.

Brad


#8

Just tried, same result (btw the folder TopTen Software was already there, so i tried removing it and starting the program in admin mode, but no luck)

Thanks


#9

Hi @brad

I think i succeded in enabling the log file, but as soon as I restarted Cantabile after saving the options, it freezes again (since I cannore remove the audio engine start and other thing from the window at the beginning)

I’m going to send you the content of TopTen Software Folder


#10

Hi @dsteinschneider

Never tried ASIO4ALL, I will give at a try this evening.
Regarding Norton software, I hope it is not the source of the problem, I just renewed my subscription for another year :stuck_out_tongue:


#11

You should read this Asus forum thread


#12

hi @dsteinschneider

Thanks for your suggestion
I read the whole thread, but it is old (2013). Nonetheless I tried everything suggested
I checked the lenght of the Driver Registry String inside CMASIOSrv64.ini and it is correctly shorter than 32 characters (they removed the “device” part in a newer version of the driver)

I also tried to disable the start of the audio engine to reach the settings, and I tried to put everything possibile (max level of detail) and I noticed more informations inside the log, and I see that the’re is no error about “opening” the asio driver for XONAR Phoebus, instead it completes the opening with success

00007271     2719   [12724:3]: Enumerating ASIO drivers...
00007271        0   [12724:3]: Found ASIO driver - ASUS XONAR PHOEBUS ASIO (x64)
00007271        0   [12724:3]: Adding ASIO driver - ASUS XONAR PHOEBUS ASIO (x64) ({E76AB7C1-855F-48FF-8B92-A4EDFEDCAE83})=ASUS XONAR PHOEBUS ASIO (x64)
00007271        0   [12724:3]: Found ASIO driver - Voicemeeter AUX Virtual ASIO
00007271        0   [12724:3]: Adding ASIO driver - Voicemeeter AUX Virtual ASIO ({BAEC28F8-10AC-4BDB-AC16-8CE24BBF8E9D})=Voicemeeter AUX Virtual ASIO
00007271        0   [12724:3]: Found ASIO driver - Voicemeeter Insert Virtual ASIO
00007271        0   [12724:3]: Adding ASIO driver - Voicemeeter Insert Virtual ASIO ({368955AF-5482-4057-AB31-D094AF769772})=Voicemeeter Insert Virtual ASIO
00007272        1   [12724:3]: Found ASIO driver - Voicemeeter Potato Insert Virtual ASIO
00007272        0   [12724:3]: Adding ASIO driver - Voicemeeter Potato Insert Virtual ASIO ({F5735BD4-6EAF-4758-9710-9886E5AD0FF3})=Voicemeeter Potato Insert Virtual ASIO
00007272        0   [12724:3]: Found ASIO driver - Voicemeeter VAIO3 Virtual ASIO
00007272        0   [12724:3]: Adding ASIO driver - Voicemeeter VAIO3 Virtual ASIO ({0239BE07-CEEF-4236-A900-AA778D432FD4})=Voicemeeter VAIO3 Virtual ASIO
00007272        0   [12724:3]: Found ASIO driver - Voicemeeter Virtual ASIO
00007272        0   [12724:3]: Adding ASIO driver - Voicemeeter Virtual ASIO ({9175CF07-885D-46B4-9EA1-4126D6648DE6})=Voicemeeter Virtual ASIO
00007272        0   [12724:3]: Enumeration of ASIO drivers finished with 259
00007272        0   [12724:2]: WASAPI: Creating device enumerator
00007272        0   [12724:2]: WASAPI: Getting endpoints
00007272        0   [12724:2]: WASAPI: Devices found: 1
00007272        0   [12724:2]: WASAPI: Found WASAPI render device #0: {3.0.0.00000002}.{6C26BA7D-F0B2-4225-B422-8168C5261E45}
00007272        0   [12724:2]: WASAPI:   - friendly name: Audio remoto
00007273        1   [12724:2]: asio - Initialising on thread 12724...
00007275        2   [12724:2]: asio - Driver created OK

#13

Just a small update,

I tried ASIO4ALL as suggested, but the behaviour of the program is the same.Looking inside the log file, now I see ASIO4ALL device among the other I already have

Is there a way to force cantabile to use only ASIO4ALL (or maybe the onboard realtek chip, just to do more testing?


#14

I have an idea. If you aren’t already using Voicemeeter for an ongoing streaming project maybe you should uninstall that and ASIO4ALL and see if Cantabile runs with just the Xonar Phoebus ASIO driver.

Terry Britton here on the forum is our resident Voicemeeter expert.

I’ve done thousands of hours of software/hardware troubleshooting going back to when I had to learn how to desolder memory chips off the motherboard my Macintosh 128k. I think you should look at acquiring an outboard USB interface such as a Scarlett 2i or Behringer UMC204HD - the Xonar board looks like more trouble than it’s worth.


#15

You might also disable any audio driver except ASIO4ALL. You do that from the tools menu, Audio settings.


#16

Some thoughts about this. From what @doGmaI has described to me in emails and from what I’ve seen in log files, it seems the problem here is that the Xonar driver hangs on being loaded - even if Cantabile doesn’t start it.

This cause the Options -> Audio Engine page to hang because it needs to load the driver to figure out what inputs/outputs it has.

I think the only solution will be to either uninstall the Xonar driver or to manually edit settings.json file to load a different audio driver (eg: the Null Audio Driver) and then be very careful to never select the Xonar driver.


#17

Hi @brad

Following your suggestion on how to modify the settings.json file, I’ve been able to correctly load Cantabile.
As suspected as soon as I go into settings->audio device and try to select ASUS Xonar, the program hangs
I tried using VoiceMeeter Insert Virtual ASIO and Voicemeeter Potato Insert Virtual ASIO and using a simple VST plugin to test the functionality (this one, https://d16.pl/frontier, I hope it’s ok for me to write the link) but the quality is really bad. Without tryin extreme configuration, I ear a really loud background noise, and if I try to speak there are only crackling sounds :frowning:
I altro tried reinstalling ASIO4ALL but the problem is the same, really bad audio
The strange “thing” is that even if I bypass the plugin, the audio is really bad, with a lot of background noise.
In the meantime I wrote to ASUS. I don’t think they will reply to me with a good news (new driver), but I had to try, who knows.

I will experiment more in the next days, when i will be back from business trip

Thanks for your suggestions (and to anyone who had the patience to follow my “problems”)
Have a nice evening


#18

I have received a feedback from Asus and, as suspected, they’re not planning to release a new driver version to fix the ASIO issue (I had to try). :cry: