Cannot get keyboard to work in Cantabile at all

Hi all,

I had a very positive experience with Cantabile a few months ago for a gig, but since then I’ve reset my computer and reinstalled Cantabile. Now it doesn’t work at all.

I have a MIDI controller hooked up. It works in every other application. I have it selected as my default keyboard in the “MIDI Ports” options screen. I know that Cantabile is recognizing it, because when I try to add a binding and click (learn), it registers all my key presses. But when I use the keyboard anywhere else, Cantabile doesn’t read it. I can’t play any patches. Even the onscreen keyboard doesn’t work. But again, under the Monitor tab, the lights for my MIDI controller (main keyboard) and the onscreen keyboard go green when I click/press them, so I know it isn’t a hardware problem.

I’ve tried another midi controller keyboard - same problem. It works fine in other applications, it reads in the Monitor and when I (learn)/create bindings - it just won’t play the racks.

It’s like something in my options is specifically telling the program to ignore all inputs for any racks. I thought it might have been something specific to the current song file, but I tried loading a song from months ago, back when the program worked, and it had the same problem.

I’ve clearly just messed up one simple setting somewhere, but I’ve been over everything again and again and can’t figure out what I’m doing wrong.

Thanks for any help

Hi @hlbuck,

If the ports are lighting up in the monitor panel then almost certainly the keyboard is hooked up correctly. My best guess would be that you don’t have a route from the input port to the plugin you’re using.

eg: the Input Ports section should look something like this:

Failing that, perhaps post some screen shots of your song and/or MIDI ports settings.


Brad - thanks for the reply, and sorry to bother you since just a couple minutes ago I got everything working. I think I stumbled upon adding the keyboard to the input port, as in your screenshot.

Wondering though, does every rack need to have this input added, or is there a way to apply it globally? When I try to add input/output ports on the main Routing screen, the options it gives me are just all the racks, not the plugins within the racks.

Not really following what you’re saying here. Inside a rack you can create a route from either an Environment port (eg: Main Keyboard) to a plugin and that rack will automatically connect to the main keyboard port in every song. Alternatively you could create a route from the rack’s MIDI input and then you’d need to wire up the rack in the parent song.

Perhaps can you post some screen shots to clarify where the problem is?


Actually, a diagnostics screen might be helpful here. Something that looks for potential problems in connections and routes. I’ve spent some time trying to work out why something hasn’t worked because I’ve missed something minor.

E.g. is there an audio device, is it enabled, is it routed to anything, is there a midi input device, is there a vst that generates sound, is connected properly, is the volume up, not muted, are all the gains set properly, is the inbuilt limiter set to something crazy, etc

Just a thought - not important.

I think the problem is resolved.

It seems once I added a keyboard route to my VST plugin in one rack, the change automatically occurred in all other racks. Anyway, thanks for all the help, I know this got confusing.

This is unrelated, but there seems to be an issue with the “Automatically update states” option in the Edit menu. There’s something like a five second delay before updates actually occur – so, if you’re quickly clicking through states and switching racks on and off, you’ll go back and find that most of your changes were ignored. Fortunately, manually updating the states (Ctrl + U) works, it’s just a minor extra step. This is something I had a problem with months and months ago, so now I understand what was causing it.

That doesn’t make sense - unless you’re talking about one rack that’s used across multiple songs (otherwise the contents of all racks are completely independent).

The automatic state updates are applied when leaving a state. eg: when you switch to another state the previous state should be automatically updated when you switch to another. I can’t imagine how this might be timing related unless there’s some overlapping operation happening - but I can’t think of anything off hand.

Any chance you can create a simple scenario that demonstrates this problem and email me the files?