C3 Hanging repeatedly build 3702

I have started to get hanging issues where everything including audio driver stops and I get the Windows hourglass. Did it once today for about 5 secs, I rebooted, played for a bit and it hung again for a couple minutes and stayed hung so did a hard reset. Played for a few minutes and it hung again for 5 secs. I have the log file attached but I can’t figure it out.

I wish I could say exactly what has changed recently on my system, but I went through some major issues the past few weeks with a particular rack not playing 3 specific sfz files, then my interface wouldn’t connect, etc. So I’ve had to do several things. I updated my interface driver and got a new TB cable (the old cable was the root cause of the interface not being recognized), rebuilt the rack from scratch with a new rack, got rid of Fishman Tripleplay vst which had caused occassional crashes only when editing (it’s only standalone now to check string sensitivities, no dll file in the vst folders).

Also, I’d been using Avast for about 2 years and disabling it except for updating and downloading new vst’s. When I started having issues I uninstalled it and used Windows AV/Firewall instead but the notifications wouldn’t stay off, so I reinstalled Avast. Seemed to be OK for a few days but then this happened today. I’m going to uninstall and see if that solves it, but I’d like to know for sure if that’s my issue or if it’s something else. Any help is greatly appreciated!
C3 Tom W log.zip (34.0 KB)

After uninstalling Avast and playing for an hour no hanging… so hopefully that’s the solution. And although Win 10 Security notifications wouldn’t stay off before (although I’d turned them off several times), for the past hour they’re off. fingers crossed!

1 Like

Darn, the problem is back. I grabbed the log file right after it happened… everything stopped/audio driver off, everything apparently then re-started if I’m reading the log file correctly. But unfortunately I’m not very experienced on troubleshooting the log file so if anyone can figure out what’s going on please let me know! Thanks!
Tom W Log 1-12-23 .zip (68.0 KB)

Hi Tom,

I’m not too experienced at Cantabile troubleshooting but I looked at your log and noticed it crashes right in the middle of loading MIDIGuitar2-64bit

Not sure what this means but it’s in the log also:
01599912 502 ! [09132:1]: CoreEngine - Audio mix batch failed to apply, aborted ramped mixer entries
01600056 144 [04660:2]: MidiDeviceManager - Found MIDI Device: input : Quantum 2626 MIDI IN
01600057 1 [04660:2]: MidiDeviceManager - Found MIDI Device: output: Quantum 2626 MIDI OUT
01600414 357 ! [09132:1]: CoreEngine - Audio mix batch failed to apply, aborted ramped mixer entries

EDIT - As usual I learn something from the Cantabile Forum. MIDI Guitar 2 looks very cool. Tracks amazingly well: Jam Origin – Audio to MIDI

Just a bit above that:

05339563        1   [09132:2]: asio - Creating buffers, count: 9, size: 64
05339563        0   [09132:2]: asio - Stopped.
05339563        0 ! [09132:0]: asio - Failed to create buffers - ASE_HWMalfunction (0xfffffc19)
05339563        0 ! [09132:0]: Audio driver reset request failed, performing full restart...
05339563        0   [09132:2]: Recorder Stopping
05339890      327   [04660:2]: MidiDeviceManager - Lost MIDI Device:  input : Quantum 2626 MIDI IN
05339890        0   [04660:2]: MidiDeviceManager - Lost MIDI Device:  output: Quantum 2626 MIDI OUT
05344566     4676 ! [09132:1]: CoreEngine - Audio engine timeout!
05344566        0   [09132:2]: Recorder Stopped
05344566        0   [09132:2]: Route manager stopping
05344566        0   [09132:2]: Starting route operation: route manager stopping
05345067      501 ! [09132:1]:   CoreEngine - Audio mix batch failed to apply, aborted ramped mixer entries

It seems that the system crashes after attempting a restart. Looking on the web for the error message ASE_HWMalfunction, I found

const (
	ASE_NotPresent       = -1000 + iota // hardware input or output is not present or available
	ASE_HWMalfunction                   // hardware is malfunctioning (can be returned by any ASIO function)
	ASE_InvalidParameter                // input parameter invalid
	ASE_InvalidMode                     // hardware is in a bad mode or used in a bad mode
	ASE_SPNotAdvancing                  // hardware is not running when sample position is inquired
	ASE_NoClock                         // sample clock or rate cannot be determined or is not present
	ASE_NoMemory                        // not enough memory for completing the request

So it could be a hardware problem, or a problem related to the ASIO driver.


1 Like

Thanks to both of you, I really appreciate that info. Maybe Brad will chime in. On the Midi Guitar, it doesn’t crash/restart on vst load or song load, or even a song state change. Each time I’ve had the issue it’s when I’m just playing. Doesn’t seem to matter which song, etc. But it’s certainly possible it’s that, although I’ve used it for 2 years without issue. Maybe a MG2 reinstall or update if there is one.

My suspicion is more on the audio driver. I had issues with the interface a few weeks ago as mentioned, then updated driver and firmware. After I posted this yesterday I changed C3 Tools settings to ignore Asio Reset, and disabled Profiler. Did a quick test and no issue but I need to play constantly for at least an hour or more to ensure it’s back to being gig-ready. My next thought it to try rolling back the interface driver until I get one that’s stable.

It’s crazy though… I love this Quantum 2626 interface, it’s been rock solid for 2 years, extremely low latency. Again, thanks!

In case it helps someone else, after more troubleshooting I’m pretty sure that my initial, main problem (not the hanging) was caused by a TB3 port that’s gotten a bit loose, probably because I leave it plugged it but it must have gotten jostled in transit too often. New cable seemed to have solved it for a while, but now i have to tape the cable a certain way to hold connection. Haven’t found anything online to suggest a fix for that yet, but for now it’s working.

The hanging issue was solved when I remembered that I had tried No Page File while trying to fix the initial issue. After initial issue fixed, the hanging appeared. Allowing Windows to manage page file definitely solved the hanging issue for me. Thanks for the help!