Build 3675 "Not responding" - something to do with multiple screens

Tags: #<Tag:0x00007f978b3e1848>

HI @Brad,

At home I have a three-monitor setup. Just updated to 3675 from 3674.

Initially, when my third screen is connected, starting Cantabile just had a white window, which I have to forcibly close. If I disconnected the third monitor, it starts fine.

With two screens connected, I then moved the running instance over to first screen, close and restart. I saw the same problem.

I then positioned Cantabile to the second screen. When I restart Cantabile it works no matter what monitors are connected.

At risk of generating a “smug report”, would this help?:

settings.3674.json:
“placement”: “1642,-37,1214,1056,False:False,1”,

settings.json:
“placement”: “427,75,1214,663,True:False,1”,

I may have seen something similar in recent builds, but just copied over working settings fil without looking at monitor setup.

Thanks,
John

And this might be of interest:

00000173 0 [02888:2]: DPI Mode: Standard
00000173 0 [02888:2]: Monitor #1: 96 dpi
00000173 0 [02888:2]: normalized bounds: [TopLeft: (-1920,0) BottomRight: (-384,864) Size: (1536,864)]
00000173 0 [02888:2]: native bounds: [TopLeft: (-1920,0) BottomRight: (-384,864) Size: (1536,864)]
00000173 0 [02888:2]: Monitor #2: 96 dpi
00000173 0 [02888:2]: normalized bounds: [TopLeft: (0,0) BottomRight: (1920,1080) Size: (1920,1080)]
00000173 0 [02888:2]: native bounds: [TopLeft: (0,0) BottomRight: (1920,1080) Size: (1920,1080)]
00000173 0 [02888:2]: Monitor #3: 96 dpi
00000173 0 [02888:2]: normalized bounds: [TopLeft: (1920,-661) BottomRight: (3120,1259) Size: (1200,1920)]
00000173 0 [02888:2]: native bounds: [TopLeft: (1920,-661) BottomRight: (3120,1259) Size: (1200,1920)]

Hi John,

Recent builds introduced some changes here because Microsoft seemed to have changed something in the latest Windows 10 that broke earlier builds on hi-dpi monitors. I’ve not seen this particular issue that you’re describing so I’m not sure off hand.

What would be best if is you could create a hang report. See the “diagnosing hangs” section on this page and you can upload the dump to here.

Brad

Thanks Brad,
All uploaded. CPU is 13.9%
John

Hi @brad,

Over xmas had a little time to come back to this, especially given I’m probably going to get a touchscreen for live use.

Build 3694.
100% reproducible:

  1. Launch cantabile (it appears on main monitor)
  2. Move it to the third monitor (anywhere, maximised/minised, doesn’t matter)
  3. Close cantabile, then restart.

The cantabile screen is white and “not responding” in title bar. I can close using the “X”. The only way to get back to normal is to disconnect monitor 3 and relaunch.

I’ve uploaded log file, dump and settings.

I also see this on Cantabile 4, but not really looked into it.

Thanks,
John

Hi John,

Thanks for the info… I’ll check it out soon and see what I can find.

Brad

Hi John,

I just reviewed the crash dump you sent… this definitely looks like an OpenGL driver issues - it’s crashing in the OpenGL swap buffers function.

You could try updating to the latest drivers for your graphics card, or you could try disabling Cantabile’s OpenGL rendering option.

Brad

Hi Brad,

This is odd. Cantabile works on the third monitor if I disable opengl from the options.

But, if I restart Cantabile after a hang and select the “disable opengl” checkbox at the “didn’t shutdown correctly” window, it still hangs.

Is this a bug in the dirty shutdown logic, or do I misunderstand what that checkbox is doing?

John

Hi @brad,

Any thoughts on this one?

John

You’re right… seems there’s a bug where the disable OpenGL in the recovery window isn’t working correctly.