Build 3595 Velocity Problems


#1

I upgraded from 3594 to 3595 and started having all sorts of velocity issues with my controllers. I use an M-Audio Code 61 and an Aurturia Keylab Essentials 61. The Code 61 would only respond if I pounded the keys as hard as I could. The Keylab wasn’t as bad, but was really inconsistent. At first I thought maybe my Code 61 was failing, but I revered back to 3594 and the problem went away.

Has anyone else experienced this? Any Ideas? Thanks!


#2

Hey Tim,

In 3595 Brad introduced inverse velocity curves. This may be what’s messing with you. This is the thread that brought it about but you need to ask @brad if there’s a workaround that gets it done for you.

Dave


#3

Tim,

I had this issue too. I had a filter velocity curve on my main input from one of keyboards. Suddenly it wouldn’t react with piano vsts. I opened up the velocity curve and it had flipped around. It was an easy fix. I went to options, midi ports, highlighted the keyboard in question, the clicked edit.

  • Paul

#4

Actually, I went to a couple of velocity curves that I had saved as filters, and they have all reversed.

Here is the filter file in 3594:

image

And here is that same filter file in 3596:

image

@brad any ideas?

  • Paul

#5

Yikes, sounds like I messed something up. I’ll look into it…


This will be fixed in the next build. If you’ve flipped the setting and saved in 3595, then in the next build you’ll need to flip it back again.

Basically the problem was related to the fact that MIDI filters had the curve amount negated for some reason. If you go back to 3594 and compare the curve in a MIDI filter to a curve in a binding you’ll see they bend the other way… (can’t remember why).

Anyway, in the next build I’ve made them consistent and updated the file save/load to compensate for the changes.

Sorry about that :frowning:


#6

Thanks. I tested it and it works now.

  • Paul