Bug: Roli Seaboard's rich data overwhelms C3?

I’ve just borrowed a Seaboard 25 and tried it in C3 and Reaper.
After a short while in C3 some notes will stop responding (and this occurs on every VST I’ve tried). If I give them a shake (lots of touches and drags) then they’ll start to play ok again.
I have not had this issue with Reaper.
A MIDI panic does not resolve it and there seems to be correct MIDI on off events going to the VSTs.
However, the data is extensive and is too much for me to read through.
It’s running in MPE mode with each note on its own MIDI channel.
I’ll capture the minimum data that creates a locked note later on.

Has anyone used an MPE controller with C3

Hi Neil,

If you can capture a MIDI recording that demos the problem and send it to me I’ll definitely check it out.

Cantabile has some internal midi buffers which although they’re generous in size they’re fixed in size (for performance reasons) - it’s possible you’re hitting a limit there if there’s a ton of MIDI data. Pretty easy for me to increase those buffers if necessary but I’d like to get to the real cause of the problem first.


I’m pleased to say that I can’t recreate this!

Great. Thanks for the update.

(Sounds like the MIDI driver might have lost the plot perhaps?)