Bug report: menu cut off on hi-resolution display

bug
Tags: #<Tag:0x00007f6af6c9a7f8>

#1

Just set up my new 4k display - set Cantabile to scale its display to 120 %, then tried to set a route - didn’t quite work:

No way to select the UVI workstation as a destination…

Here are the display settings:

Funky…


#2

Turned the scaling down to 100%, tried all kinds of setting changes. The only way to get the pop-up-menus to behave is to turn off Per-Window Resolution Scaling - but then Cantabile loses its beautiful crispness. This is with PWRS turned on:

Same with PWRS off:

all fuzzy and smeared in comparison.

Looks like something’s broken with the rendering engine.

BTW: screen resolution is 4K (3840x2160), text scaling set to 125% in Windows settings.

@brad: happy to run whatever tests you need to solve this.

Cheers,

Torsten


#3

Hey @Torsten,

I just did some tests here but couldn’t reproduce any issues. Can you send me:

  1. A debug log file
  2. A copy of you settings.json

When you say text scaling set to 125% in Windows settings, do you mean this setting:

image

Brad


#4

Hey @brad,

yes, I meant the setting you copied.

I think I found a cause (or at least a contributing factor): I looked at the “advanced scaling settings” - there is a setting that roughly translates from German to “correct apps scaling”. This was set to “on”. I turned it off, and now Cantabile’s popup menus work nicely again with PWRS.

Even more funky: I’ve now turned it back on, and Cantabile still behaves. Well, maybe it takes a reboot to re-activate, but it seems definitely worth looking at this setting.

Cheers,

Torsten


#5

OT a little, but for my main computer, I have just gotten a 5K res 27” iMAC to replace my trusty 2011 model which was now struggling. It is gorgeous in display terms, so will definitely go for a similar res on my next PC. :slight_smile:

So good to know that Cantabile plays well with such displays


#6

OK, interesting… I’ll look into that. In the meantime, glad you’ve got a solution/workaround.

Brad