Bug - Hi dpi plugin window


I suspect there is a problem with Hi dpi monitors. When cantabile (3.0.3653) is on my 4k laptop screen (set at 200%), clicking on “Add object -> plugin” does not show the pop up window and the app stays in app modal freeze until clicking on “Escape”. When I drag the main app window to my external monitor (set at 100%) then the plugin window is showing correctly and I can add plugins.

Hi @JF04

Thanks for reporting this. Which popup is not appearing correctly - the small popup where you choose what to insert (plugin, media player, rack etc…), or the Choose Plugin window where you actually select the plugin?

Also can you send me a debug log?

  1. Start Cantabile
  2. From the Tools menu, choose Open Settings Folder
  3. Close Cantabile

From folder opened in step 2, send me the files log.txt and settings.json.


Hello Brad,

It’s the plugin popup window : From the menu “Insert -> plugin” or the equivalent in table view, “Add object -> plugin” or in wiring view the “+” ->plugin.

While taking a video, moving windows around, switching screens, resizing… I realized it’s a positioning problem where the window falls out of screen completely. Looks like the plugin window remembers the size, position and display when it was last opened but the position seems to be adapted based on the display settings cantabile is currently located.

With my setup, display 1:2k@100% and display 2:4k@200% (monitor 2 is right below monitor 1), when cantabile is on display 2, the plugin window opens on display 1 out of bound. I went back to display 1, increased the size & moved more to the left the plugin window and back to display 2, now I can see a portion of the plugin window showing up on the right side of display 1 (the lower left corner of the window) but with 200% display size (setting from display 2 & looking oversized on display 1).

While this is the last “saved” values (had to exit to have the file updated), seems to be this setting (from settings.json). With the first values, a portion of the window is showing up. With the second values, only a very thin portion of the window show up.
“pluginSelectorDialogPlacement”: “568,340,811,587,False:False,1”,
“pluginSelectorDialogPlacement”: “886,344,811,587,False:False,1”,

Note: if the plugin window is maximized, there’s no problem.