BUG [Fixed]: [Responds to Master Gain] fails for Input ports

The [Responds to Master Gain] option does not seem to behave correctly on input ports.
The option does seem to work correctly for output ports.

If I turn off (de-select) [Responds to Master Gain] (in Options) for a input port, it is still being controlled by the [Master Input Gain] slider (upper right of the main screen). I would expect that the [Master Input Gain] should have no effect on the port if the [Responds to Master Gain] option for that port is turned off.

The same actions for an output port works as expected: [Master Output Gain] affects the Gain if and only if the [Responds to Master Gain] is on (selected) for that output port.

Win10x64, Build 3694 (yes, I’m becoming painfully aware of how outdated my version is …)

I am using the Monitor page to monitor each of these situations.

I do hope I’m understanding how these controls are supposed to work …

Hi Clint,

It works fine on V 3702 & 4052 here.


1 Like

Thanks for checking @dave_dore.

I’m not sure I can go to V4 because I’m tight on performance issues (pushing my laptop as it is), and I’ve been resisting V3 upgrades because things are working so well …However, this bug it a sticky thorn for me in the way I control things …

1 Like

I am now on v4052 (yay!) and, based on my (possibly mis-) understanding of the function of [Responds to Master Gain], this option is still failing for input ports. The [Responds to Master Gain] option seems OK for output ports.

Screen shots won’t really show what is happening, so I will give an outline:

  • I have an input port Mic1. It is configured with:
    [X] Enabled
    [X] Responds to Master Gain
    [–] Responds to Song Gain
    [X] Show in Monitor Panel
    [–] Include in Master Indicator

  • I speak into the mic and the Mic1 meter in the Monitor panel responds.

  • I turn down the [Master Input Gain] control and the response of the meter in the Monitor panel for Mic1 is reduced.

  • I then change the configuration of Mic1 to turn OFF the [Responds to Master Gain] option.

  • When I change the [Master Input Gain] control, the Mic1 meter in the Monitor panel responds in exactly the same way as when the [Responds to Master Gain] option was On.

If I follow a similar action for an output port, the last step has different results: The meter in the Monitor panel is no longer is affected by changes to the [Master Output Gain] control.

Note that the [Include in Master Indicator] option for input ports does work as expected … it’s just the [Responds to Master Gain] option for input ports that has this issue.

Hope this is clear. Hope I’m not misunderstanding how this should all work …

Here’s a diagram that’s a bit more straightforward:

This still appears to be an issue in v4055. Not sure if @brad has logged this …

There is also the pending issue that @dave_dore did not find this to be an issue in v3702 and v4052, but I’m not sure if we were looking at the same thing …

You’re right… seems to be something broken here. I’ll get it fixed.

1 Like

I can confirm that this bug is fixed (for both Input ports and Output ports) in v4056.


Fun fact, the reason this wasn’t working: the code wasn’t written.

(No idea how I messed that up).


welcome among us…

1 Like

As a code slinger (embedded systems) I can relate…

1 Like

Hmm, in my case, it would be age. :man_white_haired:

1 Like

It’s allowed esp on the old age count!

Totally unrelated, but today I made a school boy error replacing my push bike chain. I put the cost of buying the second chain down to old age…. And the fact as an old git it was easier and less hassle to get another one! Whereas my younger and impoverished self would have moved mountains to correct the cockup the hard way. :slight_smile: