[Bug]Can't edit parts on Sound Canvas VA

Just noticed this, but after build 4052, I can no longer edit the individual parts of Sound Canvas VA (64bit V1.1.6). I’m currently on latest stable 4056. I went back and tried all the previous releases and the last working release was 4052. When you select the Edit button nothing happens. Also noticed some of the pull-downs also stopped working. Still using this for some older bread and butter sounds.

Hi GaMer
Let’s ask @Brad, if he can check this anomaly.

Hi @GaMer,

Try build 4059 or later - there were a bunch of fixes relating to plugin editors. Let me know if it helps.


Same on 4061 :frowning_face:

I guess since there’s doesn’t appear to be a solution forthcoming, I’ll just revert to 4052 when I need to do any editing. Easy workaround,

Sorry, my skills on Sound Canvas are basics, is the individual parts editing window the one below?

Unfortunately the same with 4062 :worried:

Unfortunately, the Roland Sound Canvas VA can no longer be edited with build 4064 :worried: @brad

I thought I’d lost the EDIT functionality but thought I’d lost my mind. Now I’m just noticing this thread. If SoundCanvas VA is to be edited in C4127, this works for me:

  1. Use left/right arrows on left hand side to move midi channel (Scroll through 1-16 parts).
  2. Click on highlight patch sound at top right and a sound map “TONE LIST” window opens to allow picking/changing a patch.
  3. Click on left side numbers (Volume, Pan, Chorus) to enter new values with Number pad.

Cannot drag the sliders or EDIT on the bottom portion anymore. Can save the changes and they remain when opening the song again, too. The upper portion of the SoundCanvas that mimics the hardware still seems to be accessible.

Hi Helmut,

Thanks for reporting this. I’ve reached out to Roland to get updated licenses and I’ll see if I can get it fixed.

fwiw: Roland plugins are the worst plugins to keep working - they’re always breaking because they don’t follow proper Windows coding standards.


So I asked Roland to work with me to get this resolved, this was their response:

If it’s not working in Windows, they just need to do this:

Try these four steps.
If you’ve already done one of the steps, just move on to the next one.
Please be sure that you’ve done all four of the steps.

  1. Make sure that you have v3.03 of Roland Cloud Manager installed.
  2. In the Library of Cloud Manager, update any plug-ins that show an available update.
  3. Clear your browser cache.
  4. Restart your computer and start your DAW. <–very important!

Hi @easteelreath

What happens if you set Options -> General -> User Interface -> HiDPI User Interface -> Disabled.


Set to disabled which forced a restart of Cantabile, but no change. Lower portion of SC is displayed, but nothing is accessible. Can change upper half of SC. Once again, no change with HiDPI is disabled. I returned to Enabled.

As much as I liked the plugins to get that Roland sound, they were the worst plugins I have ever had in terms of stability and the mess they leave all over your system. I wanted them to install in my location of choice, not the default and that was OK first of all, but caused no end of problems when they updated to the next version and insisted on installing in the default location.

So I gave up on them.

Same here - exactly the same experience…

1 Like

fwiw: Cantabile has more workarounds for Roland plugins than any other vendor. Someone at Roland really should learn Windows programming.