BUG: Audio Port Options are not Persistent

Tags: #<Tag:0x00007ff40bd291d0>

Performer v3694 x64 on Win10x64:

Options => Audio Ports => Select an Input port => Edit =>

If I modify the Name, Aliases, or [X] Enabled, then [OK] and then [Edit] again, then changes persist and my changes show up.

However, if I modify any of the other 4 options ([X] Responds to Master Gain, for example), my changes are not persistent.

Tried this on my regular (complex) configuration as well as a pristine config loaded from scratch. Both fail. Not sure if config files would be useful.

Scratching my head …

I tested this issue in v3686 and it was also a problem there.

Appreciate it if someone could do a simple test of making a mod to an option (other than [X] Enabled) in an Audio In Port and see if it persists closing and opening the dialog. Can’t help feeling there is something silly I’m doing wrong …

Hi Cllint,

When you say the changes are not persistent could explain more? I tested the ‘Responds to Master Gain’ switch on my audio port it worked as expected. Bear in mind that the Master gain Slider referred to is on the tool bar.

Dave

Can you post a screenshot of the menu? Just to understand the context.

Thanks for assisting!

Starting from this Options screen and selecting (double clicking on) in: Bkg1 In:

I then select 4 options and click [OK]:

… Which takes me back to this screen. I double click on in: Bkg1 In

… and my four selected checkboxes have not persisted - they are cleared:

You have to click Ok at bottom of the options screen and go back to song level for the changes to stick before re-entering the options later to edit the port.

Ran it again with this sequence as suggested:

Options => Audio Ports => Double click on Bkg1 In:

Check off boxes, click [OK]

Click [OK] to close the Options dialog box

Re-open Options => Audio Ports

Double click on Bkg1 In and get this dialog with unchecked boxes:

I just don’t know what is happening …

I’ve tested with custom configurations in custom places (using config.json) and also vanilla (pristine) configurations in the standard place (no config.json file).

Thanks for that, it worked here just fine on an output connection, I’ll try the inputs. I am running latest performer version 3696 FWIW.

It wouldn’t work (persist) on audio input ports as you discovered but I am not sure why. I will investigate more and see if I can find out why outs seem ok but ins not. By the way what audio driver are you using for the engine?

Update:

I checked it on the performance rig and have the same issue as you so I would say we have a bug report for @brad. The weird thing is that in the case of the checkbox for for “show in monitor” works and appears in the monitor panel and remembers to remain there but when you return to edit the port the checkbox is empty so you can’t uncheck it if you wanted to. So I think it’s a little bug. Good eye Clint!

Cheers,

Dave

2 Likes

Could it be “gain” does not affect Input?

Using the same driver for two RME interfaces on two hosts: Babyface Pro FS and a UCX II. Same issue on both hosts / interfaces. The RME driver is v1.212, installed 11/14/2021 (but dated 5/4/2021):

1 Like

I checked, it happens the same thing that Clint reported in the Audio routing menu.
Unable to understand if it’s a bug or just my misunderstanding of how that menu work.

1 Like

I’m hoping @brad sees this thread, it really appears that there’s a problem here.

Dave

Hi Dave,

The issue with the checkboxes is definitely a bug - I’ll get it fixed.

Brad

3 Likes

Fixed in 3697 available now.

2 Likes