Bindings Not Firing

I have a series of bindings Song => On Load that send Notes to a rack. Only the first active binding is firing. Whichever one I move first fires, and the rest do not. Driving me crazy.

All bindings have Routing Mode=Continue. Delays are set with “Other binding in this song or rack” and I have tried delays from 0 to 1000 msec.

I have tried adding Note Off (value of 0) after the Note On (value 127) bindings, with no change.

If anyone has any clues as to why or what I could try … it might save my mental health

Well, I had the idea to change the bindings to firing on Triggers, which are activated on an earlier Song Load => Trigger #1000. The second and third triggers do not work on the Song Load event, but they do work if I fire the Trigger #1000 by hand.

Hi Clint,

It should work both ways, I recreated the conditions here as best I as I could and the notes all get sent by Cantabile to external targets. I’m not sure how you configured each binding but there is a switch that makes the bindings dependent on one another in a few different ways so you can insert delays between the bindings that are dependent on your option choice. Also, I have found that in these cases I sometimes need delays between each bindings execution to let my virtual rack or hardware target to catch up. But before getting into that I was wondering what the target is in your bindings, is it hardware or virtual?


1 Like

Thanks Dave!

The bindings send MIDI notes to my [Rig] Rack that enables a particular route and then reports the change to the Controller Bar. I have tried delays up to 1 second for each trigger, but no change.

I have just given up (after ≈4 hours) and now send a single Trigger, and the [Rig] rack responds and sets all three routes. That works fine.

I suspect a bug here, but it’s hard to boil it down to a simple case (and I’m playing out like 5 days a week now, so I’m pretty busy …)

Could be Clint, glad you are playing so much!!


1 Like

Did you ever get this solved?

Just have exactly the same issue, a binding that only fires on the first event:

I’ve recreated this in a route with midi filters instead, and it works

I’m on 4156.

No, I’ve never resolved this … I went to another scheme using global Triggers and had the issue (seemingly) under control. However it may have now resurfaced in this scenario: Are some MIDI controllers "Special"?

Once again … I’m pulling out clumps of hair …

Know that feeling - I’m now at the point where I’m gettng a discount at the hairdresser …