Bindings ..... Again

I’ve just upgraded to the latest, stable version of Cantabile and now all my bindings jump two stages, instead of the required one. This applies both to the Set List and to Bindings.

made the mistake of doing the upgrade having prepared for tomorrow’s session, which means scrabbling around with my mouse to change states within each song, which will be rather clumsy as I don’t have my laptop positioned near the keyboard - I haven’t needed to until now!
Any suggestions?

Hi David,

For now, see if you can go back to the Cantabile version you had installed before that worked until you have time to investigate the issue. When you do troubleshoot it I’d start with the MIDI Monitor on the route that brings the button changes from the keyboard to see what the controller is sending to Cantabile.



Can you show me how to do that, please?

I can try, a few questions first.

First off are you using bindings to change the song in the setlist and if so are the Bindings in your Background rack?

Secondly if you could can you post the song you use or rack you use that is handling the button presses from your controller keyboard or pedal board?

As before, yes I am using bindings to change song states, and to change songs in the set list.

Because budgets are limited I do not have a MIDI control surface or pedalboard. Because of the type of music I play live, I do not use the top octave, and therefore use the notes of that octave for the bindings, as you can see in the screenshot.

Al of this has been working seamlessly for many weeks, and the problem has only arisen because of the upgrade. Going back to the previous version would probably help, but I do not have the version number I had before the upgrade!

Hi David,

Thanks for the details. You can find out what version had installed by going to the settings folder for Cantabile. To get there go to to options & then to diagnostics and then click the settings folder button.

When the folder opens look for the last version settings file you had. Then re-install it and see if corrects it. If not you may need to rename the current settings file in that folder to something like settings_old.json and then rename the settings file with the same version number as what you re-installed to just settings.json by removing the version number from the file name. Then restart Cantabile. From viewing your Background bindings and hearing the explanation of your trouble it sounds like more than one route is processing note inputs if you are getting double jumps. Before you change things if you would start C3 do a few notes to change states to verify it’s jumping more than one space on the states list and then before you shut down make sure the settings folder is open and then post the log file here so I can check what’s happening.


1 Like

Thanks for that, Dave. It is the latest version which has brought out the problem, build 3702. The last build I had was 3694, which I have found in the Settings folder, but when I click on settings.json Windows asks me what app I wan to open the file with.

I don’t know the answer to that, neither do I know how to re-install the last version.

A development for when this is fixed is that my volume pedal is now making crackling noises through the PA which make people jump when they are supposed to be in a worship mood! I have gone in the past for budget pedals, which didn’t last, then consequently bought a Boss one, but it too hasn’t lasted long. The Yamaha replacement is well pricey, so I have gone the whole hog and bought a Behringer FC 1010 MIDI Pedal Controller, similar to the Roland controller, but within my budget. I know, I’ve gone for cheaper again, but it does have a good reputation, and enables me to do volume controller using CC numbers, so no crackles! It does also mean that my bindings will no longer be the top octave keys, so now I can do keyboard splits without any worries! It is due to arrive by Wednesday.

Next is to monitor the MIDI input when I try to activate the bindings, so will get back to you with that in due course.

HI again!

I loaded a random song, then found it had the bindings within the song, so the first part of the log will not be relevant, so then I loaded a set list from yesterday, and did a couple of state changes and back again, followed by a couple of set list song changes and back again. (8.7 KB)

I hope this helps.

Re-download it from this link and run the installer …

I’ll check it out but the fact is you can only have those bindings in the song or the background rack but not both. Delete the duplicate bindings in the songs is what I’d do next and keep only the background rack bindings.


Actually the random song I had loaded is probably the only one with its own bindings! When I first raised the issue, I responded to the advice by deleting all the in-song bindings, except that one! So since then all the bindings have been from the rack, and have worked faultlessly, until the update.

Many thanks for your help so far!

Dave with sausages for fingers!