Background Rack no output

Tags: #<Tag:0x00007ff4203ee268>

Hi all, I’m new to the forum but a big Cantabile fan, using Performer for several years. I’ve recently bought an iRig Pro Duo I/O for rehearsals and simple (i.e. one-keyboard) gigs.
I have the iRig’s 1 & 2 inputs defined as a stereo input channel in the audio engine, and I want to mix my Nord’s analog output with the VST’s. If I route the stereo input to my main output mix in any song, I hear the Nord and all is fine. However, if I do the same in my Background Rack, I don’t hear anything, even though the Background Rack audio level meter indicates normal output levels. Why am I not hearing the Background Rack output?

The Background Rack output isn’t routed anywhere directly, so you won’t hear it. If you want to hear anything from the Background Rack, you’ll have to route audio to a physical output (e.g. “Main Speakers”) within the Background rack. For that to work, you’ll have to enable “Show Environment MIDI and audio ports in racks”):

2 Likes

Hi Torsten, thanks for replying. Yes, that is what I have: the Background rack is routed to my main “Mix 1” output (rather than to the output of the rack itself). But no sound. If I do the same thing in a Song (routing the Stereo in to the Mix 1 output), there IS sound.
So, the Background rack output somehow does not reach the Mix 1 output, even though that is the endpoint of the rack.