Auto-naming for new Recordings not working suddenly

Currently on version 3159

I am using this structure:

But only getting a line.

I haven’t recorded into the program at this computer in a couple weeks (worked as of 2/29), so I’m not certain when it started.

Last version it was known to have worked on was 3151. (Loaded it in and tested and it works fine.)

3158 and 3159 do not. I don’t have previous versions on this computer other than 3158 and 3159, but I have them elsewhere if you need me to hunt.


I spoke too soon about it working always in 3151. I did three tests, and the first two concatenated with the same name. The third test showed the line. Here are my settings:

Notably the counter did not auto-advance either. The recordings were all at least 10 seconds long.

The one thing I did differently between the working ones and the non-working ones was to add a binding to the Record start/stop. I used MIDI controller 116 in the Background Rack.

I’m trying re-installing again.

Nope. It is having trouble getting info from plugins now, where that worked flawlessly before. I hope I didn’t break that functionality!

Other naming functions seem to work ok. The counter has to be the last item on the list, it appears.


I exported my bank of favorites and deleted the broken plugins from their racks and placed them back again, and then the auto-naming with the plugin and patch name worked again.

I have no idea if it had anything to do with my putting a recorder binding in the Background Rack. Still testing.


Hi Terry,

I can’t think of anything in this area that has changed recently, but I might have a clue as to what’s happening… the selected plugin variable really does require a selected plugin. If you’ve viewing a rack (eg: the background rack) with no plugins it won’t pick up a name.

This is obviously not ideal and I’ll need to think about the best way to fix it - these variables pre-date Cantabile 3’s racks and they’re a bit unpredictable.

In the meantime if you could confirm this is what’s happening for you.


Will do later today, but that certainly sounds logical. I was in the Background rack adding that binding when this happened. So, I suppose I need to be in the rack having the plugin, or create a rack-less version if I’m just using it for creativity and bouncing around between plugins then, correct?

I’ll try all ways later! :smile: