Audio Ports periodically lose assignment - Win 7 [32 bit]


Issue just started recently where the Audio Ports all of a sudden show “Unassigned” and couldn’t seem to get the application to find any possible options to reassign them.
Left / Right and the Metronome are always set to “HD Audio input” - using ASIO4ALL which hasn’t caused any issues before.
I lose sound completely including the Metronome but the signal is still there when I test the instruments.
“Fixes” I’ve tried - sometimes restarting Cantabile works, sometimes just hitting the Power button works, and sometimes none of the above and restarted my laptop.
Been trying to see the pattern but nothing has shown itself yet. This has occurred I think 4 times now.
Running Win 7 [SP1] 32 bit.

Thoughts? Anyone else experience this? Is there something I can do to force a ‘rediscover’ for a lack of a better to describe it.

Cheers, O

Have you seen this happen after changing the audio engine, perhaps?


I have some MIDI port criss-crossing that goes on if I let the computer sleep with Cantabile running so I’m mentioning that possibility

@terrybritton - On my laptop I don’t explicitly change the audio engine - Asio turns on only when I start Cantabile, so the auto default is whatever they call it that comes with Win 7.

@dsteinschneider - I do leave my computer on [more than I should] only putting it into hibernate mode when not in use but if I’m not using Cantabile I shut it down. In fact no need to leave it running because of the ‘save settings’ functionality, which I love. Brilliant if Brad reads this!

I did think it was due to some software that has a MIDI component to it - had to install/uninstall and I “thought” that was perhaps the culprit because literally that evening the behavior started. However, all the stuff I was testing got fully removed and I even did a system restore, only to have the same behavior occur again the next night with what I though was causing the issue fully removed.

I haven’t used Cantabile in a few days so…

Question: Is there a way to “discover” the audio engine? It’s been so long time since I set Cantabile up and I can’t remember if that was an automatic process or not. I’m pretty sure Cantabile does automatically from which you then select. The into tutorial with the channels is confusing to me but I digress…

You have to explicitly set the audio engine. From the Audio Engine tab in Options.

That’s really all there is to it.


1 Like

Ok thanks, and good to know I was doing the right thing.
For the record that behavior thankfully hasn’t occurred since.
Having spent 20 years in IT I’m convinced these systems develop a mind of their own :smile:


Heh! And no two computers aren’t working right for the same reasons!!! Ever!!!


1 Like