Audio glitches after upgrading to Performer

audio
performance
Tags: #<Tag:0x00007f52c2e48d08> #<Tag:0x00007f52c2e488d0>

#1

I spent time going through Glitch free and other guides. I had Cantabile running pretty smooth. Only time I ran into audio glitches were troublesome plugins. So I finally had a the ones i liked.

I wanted to use some of the features of Performer so I upgraded. No i run into audio glitches. After loading a song notes will sometimes stick. I also get those droput/clicking audio glitches.

I have tried different audio settings and using the onboard sound vs my focus Scarlett audio.

So I am looking for tips on tracking down and fixing the issue.


#2

Run the profiler under the “view” tab to see if you can determine what is causing the glitches. What buffer size are you using on your onboard sound, and your Scarlett?


#3

Running the profiler. I will get a spike randomly. It does not look to be the sample plugin or pattern.

Scarlett
Focus ASIO
sample: 44,100
buffer 352

Odd but I seem to get less glitches when running the profiler. Can you save a profiler session?


#4

@oddfact Do you have LatencyMon (diagnostic tool)? Sounds like ndis.sys network driver.


#5

@RackedBrain I ran LatencyMon. (good call on that I forgot about that tool). I thought ndis.sys would be the biggest issue but the biggest issue is storport.sys and usbport.sys. Now to trouble shoot those.


#6

Yes, from the hamburger menu in the top right hand corner:

image

If you can capture a couple of these spikes/glitches feel free to send me a profiler session showing it and I’ll take a look. Even better if you can capture it with profiler level set to “Detailed” (in Options -> Diagnostics -> Audio Engine Profiler).

Brad


#7

Sorry @brad for the long delay. I had a windows user profile issue and ended up resetting windows and reinstalling everything. Upside I am getting a clean Latency Monitor reading. The usbport.sys is still the highest use but now in the green.

I am now running the latest Cantabile 3587. I went though the glitch document to make sure all the tweaks and settings were still in place.

Using the Focusrite AISO
Sample Rate: 41,000
Buffer Size: 440
Audio Threads: Automatic(2)
Multi-processor: Compatible
Thread Affinity: Preferred
Prevent Memory Paging: Disabled
Sample Rate: Good
Power Plan: Optimized to glitch standard
Enable Output Limit: 80

@brad I will send a profiler session.


#8

Hi @oddfact

Thanks for sending through the profiler log. I’ve checked it out and in all cases the stalls were caused by plugins. Here you can see, Cantabile is running smoothly but the actual call to the plugin (ie: the plugin doing it’s processing) stalled:

image

The one case where Cantabile itself stalled was here but that was because it was waiting for the other (stalled) instance of (Xpand2) to complete. What do you have Options -> Audio Engine -> Multi-Processor Mode set to? (aggressive or compatible). Switching to aggressive might help that second instance, but not the original stalled instance.

image

This happened with two different plugins (xpand2 and SynthMasterPlayer), so my guess is this morely is a system configuration thing than a problem with either of these plugins and unfortunately probably your best bet to diagnose this is going to be trial and error. I’d try disabling things like wifi, bluetooth, onboard sound card and see if any of these make a difference. Also, as an experiment try a different audio driver.

Also you suggested this started when switching to Performer… just to double check I’d be interested to hear if this still happens if you switch back to Solo. (I’ve issued you a license for Solo so you can try).

Brad


#9

@brad The original issues of notes sticking does not happen anymore. I also seem to have the issue in Performer and Solo.

I think what I am running into now is a different issue than the original one since I had to reinstall everything. I do not remember having issues with synth master or Xpand earlier. Those two seemed to play well.

I will start going down through list to disable. I have not reinstalled AISO4ALL yet. I will check that as well.

Right now I am running everything in 64bit, would going 32bit help?


#10

Probably not, but worth trying.


#11

Thanks @brad. I found one issue. The BIOS was set for RAID I changed that to AHCI. Getting better results now. Since this is not really Cantabile related but system related I am thinking I should start a new thread on the Latency/DPC issues.

Thanks for the great software. I keep trying to learn to use ableton for live performance but Cantabile is so much easier to use.