Audio engine management

Tags: #<Tag:0x00007f9787d46518>

I am often working on my setup away from the keyboard and the soundcard, thus getting an error message when starting Cantabile, and the result is that the audio engine is turned off.

Suggestion 1: rather than giving an error message, it would be nice to get the let list of available audio drivers (incl. Null audio) to select from.

Suggestion 2 (nice to have): having the option to mark a specific audio driver as ‘default’, thus always using that driver if it is available.


I’ve previously requested command-line override for any config parameter. This would help here?

You can setup different configurations like so:
And there’s a command line argument to select a configuration.

1 Like

Thanks, and yes, that might just be the way to handle this.

Yes, but the pain is keeping those in sync, particularly as you only want to change one thing.

Yes, but it’s still a pain when you want to work on your live config, but on starting you keep getting the audio driver error messages multiple times.

I have different configs on my machines, one for my main band, another for the second band (different set list, different audio device), and a third one for just testing things. Still is a nuisance having to click through the audio error messages when just opening e.g. the “main band” config to make changes to the set list.

My preference would be to have the option to turn audio engine error messages off and simply have the audio engine on/off switch (top right) turn red or blink when the audio engine can’t be started. Message is clear enough, and I don’t have to mess with all the alert messages.

Also: can we please NOT have the audio engine alerts any more when opening preferences? This is sooo annoying and disruptive, when going to settings to change the audio engine - YES, I KNOW THE AUDIO INTERFACE ISN’T CONNECTED - THAT’S WHY I’M GOING TO SETTINGS :angry:

Simple way to deal with this would be to just have the specific audio engine settings marked with an alert symbol or colored red or whatever within the settings dialog - but let’s lose the friggin’ alert boxes… @brad: pleeeeease! When you’re done with the new GuiKit…




I totally agree with @Torsten. Maintaining several bands has been a challenge, but I have it down to a science. I understand the alerts, but having it pop up several times when trying to get to the Audio Engine is very frustrating. Before I became a somewhat keen user (loosely applied), the alerts led me to the reason I had no sound. But now, I would prefer a choice for alerts, or no alerts. For me, this is not a needed emergency fix… just a future feature.




I like this idea.

This seems reasonable too. Leave it with me… but ping me if I appear to have forgotten.


Would it be possible to have a third state, i.e.
green = audio engine started and sound card running
yellow = audio engine started but with null audio
red = audio engine off
The reason for this is that I also works with midi settings/configuration while away from the keyboard, so I need the engine to run to test the midi stuff, but I don’t necessarily need any sounds for testing flows/logic.

Curious what others think about this. Don’t forget there’s already an orange “busy” state for that button too.

1 Like

Oh, I was not aware! I want it painted … black? No, hard to see, will blue be an option?

:notes: I see the engine and I want to paint it black…
No colors anymore…I want it painted black…


I’d build on the current color scheme:
– existing–

  • green: audio engine active
  • grey: audio engine inactive
  • orange: “busy”

– new stuff–

  • blinking red: problem with the audio engine (usually: couldn’t start the driver). Blinking gets your attention but isn’t as intrusive as the alert boxes.
  • blue: null audio engine active

Coming to a v4 near you soon:

  • Power button colors as per above post (including flashing red for error and blue for null audio)
  • Error messages on failed to start audio drivers suppressed - except in the one case where you actually press the power button and it fails.
  • Failed to start errors shown in the power button tooltip.
  • Error messages in options dialog suppressed.
  • “Failed to load” message on the audio ports page if the current driver couldn’t be loaded.

Nice !!