Audio Driver Stopped Working; Reinstalled; Can't fix

I’m at a loss. One day my driver stopped working - it’s the Yamaha steinberg USB ASIO driver. I reinstalled everything (the ASIO driver needed to be updated actually) and also reinstalled the ASIO4ALL driver. Now it appears to be running - no error message - but it’s not picking up any midi inputs. Tried restarting and everything else I could think of.

How can I troubleshoot? What can I do?

Thank you so much for your help!

Hi Lauren,

Welcome, The place to start troubleshooting is the MIDI Ports settings. Go to Tools>Options>MIDI Ports and find the name of your Yamaha MIDI Ports. Select ‘Edit’ for the port and carefully check the checkboxes to make sure your device is selected.

Many times when there is a physical port change the device will show up as disconnected (because it’s not in the same physical jack), there will be another copy of the same device in the list that that will report as connected but needs to be manually checked to get things going again. Remember to drag the bar on the checkbox list as some times things get hidden.



And the other thing might be to just do a system restore from a point before the issue occurred, and maybe then you can pin down what changed. (Hope it’s not actually hardware related…)

1 Like

Dave - You are a lifesaver!!! thank you so much for the help. That worked - though I did need to scroll down. Thank you!!

1 Like

Fred - Thanks so much for the help! Glad I didn’t need to do a system restore.

I use the same driver. I’ve found that starting Cantabile before connecting the keyboard via USB causes this. So far the Yamaha driver has been the only one I’ve had this problem with. I’m guessing it is allowing C3 to grab exclusive access even though the hardware isn’t available, and then creates a new instance of itself when the hardware becomes available. As this is kind of a PITA to fix at a gig I make sure my USB before starting C3 and turn the Engine off if I have to walk off with my Surface.

Ah- I’ve always done that as a matter of habit. I guess it comes from the old analog mentality that always powers up board first/ power amps last :wink: