Audio distortion with ASIO4all

I’m running Windows 10 on a Toshiba Satellite Pro laptop (I-7 2670QM, 6gb RAM). I’ve been using ASIO4ALL with my internal sound card (Realtek HiDef Audio) for VST’s in Cantibile for serveral years. Recently I purchased a new VST- UVI Workstation Wurli, which is a sampled VST. This is the only sampled VST I’m currently using.

No problem until I switch to a song which uses this VST, then I get extreme audio distortion. All I have to do to get rid of the distortion is to open the ASIO configuration window and close it. I don’t need to click the parachute or change any settings in ASIO4ALL.

Obviously, this particular VST is overtaxing ASIO as I don’t have this problem with any other VSTs. I’m wondering if there’s something I can set within Cantabile or ASIO4ALL to correct this problem, or is it because I’m using my laptop’s internal sound card?


I also have UVI player. Does the distortion occur when you load UVI and before you load a sample set (ie Wurli) or after?


I believe it’s occurring in response to Wurli being loaded

Hi Lee,

A couple of questions:

  1. Are you seeing load spikes at the time of loading UVI and afterwards? Wondering if this is a sample conversion/manipulation type problem, or related to excessive load and not keeping up.

  2. Does turning Cantabile’s multi-core support off and loading just UVI work?

  3. Does UVI have a multi-core option? (can’t remember off hand, but if see, see this)

  4. Does closing UVI while the distortion is happening and loading another instrument return to normal sound?

  5. What is the Page Fault (pf) reading doing during all this.

  6. Does it only occur immediately after loading the plugin or if you let it sit for a while do things return to normal.

(Sorry for all the questions… just trying to break down what this might be).

  1. I do not see loading spikes

2.Haven’t tried that yet.

  1. Can’t tell. There’s nothing in the Settings section for UVI, so I assume not.

  2. Within a session which has UVI and Lounge Lizard, switching UVI to inactive (orange) and switching LL to active causes the distortion to stop.

  3. PF %ages range from 7 to 10.

  4. Happens on load. Distortion doesn’t go away until I intervene by opening and closing the Asio4All window, or as I just found out, switching off UVI and switching on another plug in. I didn’t try just switching off and back on UVI and leaving the other plugin off.

Update: it doesn’t just occur on load. After I cleared the distortion by opening and closing the Asio4all box, the sound remained clean for a few minutes but the distortion returned. Stop playing for a few minutes and return to the keyboard, the distortion is gone.Turning the plugins on/off does not cause the distortion to go away. Only opening and closing the ASIO box eliminates the distortion when it’s active. Also realized I was looking at the wrong PF numbers. When I’m playing they usually range from 1 to 10 but occasionally spike up to 200. Seems to be no discernible pattern.

I noticed in the ASIO config box that two devices are activated. Click for picture link. Part of the problem?

1 Like

Hi Lee,

Page fault counts seem reasonable. I would try disabling one of the devices in ASIO4ALL and see if that helps. Also still interested to hear if disabling Cantabile’s multi-core helps.

Another thought - what happens if you record it with Cantabile’s recorder? Is the recording distorted? That would help isolate it to either a UVI/Cantabile issue, or a sound driver issue.


Hm, what about the iConnectMIDI2 device? This sounds like an outboard audio interface. Afaik asio4all can handle more than one interface at a time in theory - never heard of a proper running system in reality (but may be wrong here). Could all the trouble ve initared here?

The recording was distorted too.

I diabled multicore support, distortion stopped.

Won’t have much time to play with this again until later today.

OK. I’ll try to reproduce this but possibly won’t get to it for a couple of days.

What CPU is your machine, specifically is it hyper-threaded?

Does this help? link to processor description

Hi Lee… yep hyper-threaded. In Options -> Audio Engine, the number of audio threads has probably defaulted to 4. Try changing to 3 and let me know if that improves anything.

I’ll do that and get back to you

Back to you - Still getting distortion with 3 threads enabled.

One other thought. Do you think it would make any difference to turn off hyperthreading in my processor?

Something very strange has happened. So… I decided to upgrade to the latest build, but instead downloaded the latest stable build and didn’t realize until it was too late that I had installed build 3084. Once I realized what I had done I upgraded to the correct build (3096). It installed fine, but now ASIO doesn’t work. I’m getting audio output indicators all plugins indicating that an audio signal is being sent. My sound card is working- I can hear test signals when I run the configuration utility on the card.

Out of desperation, I decided to try using the WASAPI audio driver, which works just fine. Sound is back. And oddly enough, UVI Workstation Wurlie is (so far) working just fine with no distortion.

The question of course is what the heck happened, AND is is OK to continue using WASAPI as my audio driver?

1 Like

Hi Lee,

It’s a bit hard to tell what’s happened from here, but if you open the ASIO4ALL control panel (Options -> Audio Engine -> Control Panel) does it show your sound card as available or crossed out?

Other things to check:

  • Make sure you don’t have the Microsoft Wavetable GS Synth enabled in MIDI Port options
  • Check that your audio port are mapped to the sound card in Audio Port options

Also, when asio4all is in this bad state, what happens if you start Cantabile and then turn the audio engine off then on again?


It might… it’s certainly worth trying - even if just to establish if this problem is related to hyperthreading.

Control panel shows everything to be in order- no X’s.
Audio ports are properly mapped
Turning audio engine off, then on again makes no difference

Since I’ve set my audio engine as WASAPI, I’ve had no more distortion from the UVI app. Latency seems very negligible. Any reason I shouldn’t keep audio settings as they now are? From what I’ve read about WASAPI, it’s a Windows 10 low latency audio app. Articles I read tended to be very technical. Is there a way to make adjustments in WASAPI similar to what can be done in ASIO?

Hi Lee,

If wasapi is working for you then by all means stick with it. Mostly I’ve found that audio drivers either work, or they don’t. Cantabile support for it is a little limited at the moment though - in particular only audio output is available via wasapi.

There are no further settings for wasapi that I’m aware of.


I forgot to say that I’m still somewhat baffled by why your ASIO4ALL has stopped working. Perhaps if you sent me a copy of your log file, settings file and a song I’ll take a look see if I can spot anything.

Maybe similar with me, 64 bit works fine build 2072.
Installed t, build 3126, and no sound