Asio input/output problem


#42

Thanks Dave, yes that is what I was missing, thank you.

But, and now I really feel like I’m being annoying, but I have once again run into problems I don’t know how to fix, and one of them is pretty wierd.

All I want to use, are two VST plugins, an EQ one (most likely I will use ReaEQ) and another one called TriLeveler which is a compressor+gate in one.

If I can’t get any of this to work, it’s fine, because I can use Reaper to do this, but I will end up with a separate audio track I will need to re-render the video with. Not an issue, as this is how I have always done things, but I would prefer to do it this way as it saves a bit of extra work.

So, the problem with each of those two plugins is different. The ReaEQ (and this same problem occurs for absolutely every plugin I try except for TriLeveler) I get this horrible buzzing sound, it’s like a cross between a digeridoo and bagpipes, and it is always audible, whether I am monitoring my mic or not. Bizzare indeed no? Also I do see the plugin react to the sounds of the mic, so it is getting the audio.

Now onto TriLeveler, it looks like it is receiving my voice, because I see the bars react on the plugin when I speak. But I don’t hear any actual difference, I moved the sliders to the point where there should have much distortion of my voice but again I hear no change.

I never used the two plugins at once in these tests, only one by one. If these problems are too weird to try fixing it’s fine, you guys have already gone above and beyond the call of duty helping me with this. Maybe it’s just not meant to be.


#43

Hi,

Please post screen shot of latest routing and also what asio driver are you using for Cantabile (Tools>Options>Audio Engine)?

Thanks,
Dave


#44

OK, I took a double screenshot just in case something on voicemeeter will reveal anything (should have had this idea yesterday really).


#45

In the first hardware input on the voicemeeter screenshot I always have mono enabled, I must have accidentally disabled it in that screenshot but the mono button is always enabled (since the sound will only come out of the left speaker if it’s not enabled).


#46

what audio driver does Cantabile use? (Tools>Options>Audio Engine)


#47

Saw this from above. Did you try this?


#48

Sorry, I completely missed that question.

I enabled and disabled the cantabile audio engine many times, it never made a difference.


#49

Ok, the sample rate in Cantabile does not match with the Voicemeter virtual input. try adjusting The Sample Rate in Cantabile to 44100Hz and the buffer to 4096. This would match the setting you have in voicemeter virtual channel.
It will also introduce some audible delay. You could leave Cantabile alone and change voicemeter’s VAIO settings to match Cantabile’s current settings ( from above these are 48000hz and 512 for buffer size ) I think that’s why you have a ringing, it usually points to a sample rate mismatch. Hope this helps.

Dave


#50

I tried to find where/how to change voicemeeters vaio settings but I failed. Here is a screenshot of two of the settings windows. It looks to me like everything is already set to 48000/512.

I don’t really know if those screens are relevant but here they are:


#51

Hmm that all looks good. I’m about out of ideas on this one. Maybe @terrybritton can see what’s wrong I can’t.
Good luck!

Dave


#52

I managed to get the sample rates to match cantabiles 44100/512. I did this by going into my recording and playback devices in windows and manually changing them from 48000hz to 44100hz. This however didn’t make any difference, I still get that sound.


#53

Just to repeat:
Some systems have trouble syncing Cantabile with Voicemeeter, producing a distorted signal - just keep hitting the Cantabile Audio Engine button toggling it off and back on again until the distortion disappears if this happens to you.

I also find it useful to set all Playback and Recording devices to the same bit depth and sample rate in the Windows Audio control panel., like all to 16-bit, 44,100hz.

Sync problems arise when these are at differing settings.

Terry


#54

Yeah, everything is set to 44,100hz.

I tried hitting the Cantabile Audio Engine button repeatedly again and still nothing. Cantabile must just not like my system, so I think I will have to not use it. Shame though considering all the effort you put into helping me with this Terry but hey ho nothing can be done about it it seems. Thanks all the same.

Could Reaper replace Cantabile? Hmm, I may play around with that.


#55

I take it that it sounded like a robot voice? (That is the sound of sync being out.)

If NOT, then you may have had a feedback loop. If you have Voicemeeter VAIO set up as your default audio device, and are outputting the VAIO slider to B1, then you will create a loop. I get maxed-out meters when that happens. Turning down all the sliders makes it go away. (Upon my re-read of your post, “I get this horrible buzzing sound, it’s like a cross between a digeridoo and bagpipes, and it is always audible, whether I am monitoring my mic or not,” definitely sounds like a feedback loop!)

I use the AUX Virtual ASIO as Cantabile’s engine/output, and save VAIO for system sounds. That helps in controlling this somewhat.

Make some other device the default Playback and Record device for a moment to test in Windows’ Audio control panel to check whether it is a feedback loop - that may be the easiest way to test it.

Terry


#56

Also, you may find pages 39 (Getting Optimal Latency) and 45 (Known Issues and Recommendations) of interest in the Voicemeeter Banana manual found here:

http://vb-audio.pagesperso-orange.fr/Voicemeeter/VoicemeeterBanana_UserManual.pdf

Terry


#57

Terry hello!!
You have helped me before VMB and now i need more help.
I have Focusrite Scarlet Solo (2nd Gen) and i need to get it going with VMB.
It all i have going and i noticed when i switched away from Mobilepre ( which was simple and smooth )
now i have latency sample rate problems. . . help. . .
what is the best sample rate for this setup. . . i use Hangouts in my podcasts . . thats all . .


#58

44.1 is the most universal sample rate and usually provides the lowest latency due to its low demands on the system.
As long as you have the A1 audition output set to the Focusrite ASIO, the rest of the system should follow the buffer settings and latency of the Focusrite. For the other outputs, you may need to tweak a bit, but for the most part the A1 device sets up what the latency overall will be.

I take it you saw my video on using Voicemeeter Banana for hangouts?

Terry


#59

This new video might be useful to you as well.

Terry


#60

Terry . . . thanks your helpful responses. Actually i went back to M-Audio Mobilepre MkII!!!. I made sure the 44.1 was set on all devices. Actually i think that M-Audio manual states that Mobilepre runs best at 24bit 44100 studio quality. In a Windows update, i think it changed the settings back to factory defaults of 16 bit cd quality 48000 on VMB or when i upgraded the Windows 10 version to the latest version. Man was i ticked and frustrated. So my system would blue screen and crash with a mobilepre error. . . so i though it was the mobilepre now causing the issue . . i bought the Tascam 4x4 package . . it only worked temporarily as it has its own mixer and seems to clash with VMB in my opinion. Soon i could not get it to work with VMB anymore. . so i then when to Focusrite Scarlet Solo. Horrible. period. i got all driver form the web with both interfaces . . tried setting everything up . . . just horrible. So i yesterday i tried the mobilepre again . . . this time i got the original driver from the software disc that came with the mobilepre and installed it on the CURRENT WINDOWS 10 VERSION and set it to 24 bit 44100 studio quality. The drivers from the web were already installed on the system. I set all cables and all sound / recording device settings to the 24 bit 44100 and my system has not crashed yet. no click or pops. . . nothing!! crystal clear hangout with skype calling. . … no crashes at all either. … VMB set with the MMEs / Cable A / B / VB. BEAUTIFUL CLARITY ONCE AGAIN!! IT IS TOTALLY FALSE THAT MOBILEPRE WILL NO LONGER RUN ON WINDOWS 10. AND IT WORKS WITH VOICEMEETER ( EITHER VERSION)


#61

Having trouble connecting Cantabile Lite to my Focusrite 2i2. Audio from other sources on my laptop work fine. Does the “Lite” version support USB audio out? Everything seems configured OK in the CL audio panel but audio still comes out of my laptop speakers. Thx in advance for any help.