Asio input/output problem


#22

In short, I would pick the ASIO soundcard for A1 that has the best low-latency capabilities for my monitoring device, and set its buffer as low as I can without getting crackles.

Terry


#23

All of a sudden my Focusrite 2i2 has stopped working :frowning: I didn’t even get to attempt to try this.

When I connect it, nothing happens, the green light doesn’t come on and the PC doesn’t detect it. And if I reboot while it’s plugged intoa USB 3.0 socket it will not boot up giving me a usb initialization error code.

Does anyone have any ideas how to troubleshoot this?

Edit: If I press the phantom power button the red light does come on.


#24

Hi Glass_Wizard,

First make sure you plug into same usb input if possible then try system restore to last time you know it worked
Second try re-installing your 2i2 drivers
Usually if there is no hardware problems this will correct these problems.

Best of luck

Dave


#25

It didn’t work, I think it’s dead. It’s still under warranty though so I’ll return it.

Strange thing is, my old Tascam US-122 wont work either. My PC won’t recognize it but the lights do come on, they all go red which I’ve never seen before. I wonder if it is my PC. I’ve emailed focusrite support, so they should be able to figure it out.


#26

Did you see this support article on the Focusrite site?

Terry


#27

I was so close to sending it back and getting a refund! Thanks for the help guys, but I solved it, my external hard drive was shorting out my USB sockets! Yeah that can happen apparently. All I needed to do was disconnect my external HD and turn off my computer at the socket for a few seconds and presto, everythings back to normal :smiley:

Now it’ time to get cantabile loaded up, I got me some learning to do :slight_smile:


#28

Back to the topic. In the HiFi Cable Control Panel I guess I should enable ASIO mode? And I should choose my soundcard as the ASIO device correct?


#29

Just checking on this detail - how will you hear your audio if you use HiFi Cable? Why are you using that instead of Voicemeeter?

Terry


#30

Sorry, did I do something stupid? I must have misunderstood something. Are you saying I don’t need to use HiFi Cable at all, I thought I had to use both voicemeeter and the virtual cable, looking at the screenshots above it seems that’s case? I installed both virtual cables just in case one didn’t work.

I haven’t had the time yet to sit down and go through the guide you wrote, but I am free in 2 or 3 hours and I’ll go step by step through the whole thing.


#31

So, I went through and did what you wrote and it cleared up the confusion I was having. In the end set up, the virtual cables are not used.

However I must have done something wrong because OBS doesn’t record any sound, not from the mic nor the computer itself.

Here are the relevant screenshots:

I can only post one image per post so I’ll post the last two in separate posts.


#32


#33

This site is hiding my posts because I’m using images. So I’ll post again, one image per post.

So, I went through and did what you wrote and it cleared up the confusion I was having. In the end set up, the virtual cables are not used.

However I must have done something wrong because OBS doesn’t record any sound, not from the mic nor the computer itself.

Here is a screenshot of Voicemeeter.


#34

Damn it, this site is preventing me from posting images of OBS and Cantabile and removing my posts. All I can say is I did what you said, but OBS doesn’t record any sound.

In voicemeeter I set A1 to WDM - Speakers (SoundBlaster Z)

In cantabile I set the audio driver to ASIO - Voicemeeter Virtual ASIO

Then in OBS I set desktop audio device to Line Out (2- Scarlett 2i2 USB) and the Mic/Aux Audio Device to Voicemeeter Output (VB-Audio Voicemeeter VAIO).

Did I do something wrong?


#35

Yes. But only one thing I can see. To review:

In OBS Classic, set OBS Desktop Audio to point to something you do not use at all. If using OBS Studio, just set it to disabled.

Set OBS Microphone to Voicemeeter VAIO. Be careful you do not select the AUX one, as the titles are so long in the Classic version as to have their ends obscured.

The A is for monitoring only. The B is for what you send to OBS. B1 sends to VAIO, B2 to AUX.

I’m about to make a video on the process, as I found out some useful things. I will be covering using Voicemeeter Virtual ASIO VAIO and AUX first, and in a separate video will cover using Cantabile with Voicemeeter Virtual ASIO Inserts instead. Both methods have their benefits, and with both you can send stuff back to Cantabile to use its hosted VST effects with your hardware ASIO interface, if you have one or get one.

For now, keep it simple.

Some systems have trouble syncing Cantabile with Voicemeeter, producing a distorted signal - just keep hitting the Cantabile Audio Engine button toggling it off and back on again until the distortion disappears if this happens to you.

Also, watch out for feedback loops. This is the best thing about using the Voicemeeter Virtual ASIO Inserts - it avoids that problem ever cropping up.

Remember - as we are using Voicemeeter’s Virtual ASIO from Cantabile as the audio engine. Voicemeeter then acts as a go-between to send WDM to OBS.

Terry.


#36

Yes! It works :smiley: Thank you very much Terry.

There is one small thing that I’m not sure how to fix though, I just added an EQ effect in cantabile, then I enabled the A1 button in voicemeeter to hear myself but I can’t hear the effects of the EQ plugin. I moved all the bands to the bottom on the EQ plugin which should have pretty much completely destroyed my voice, but I didn’t hear a single change.


#37

Hmmm - yet you can hear yourself without the EQ?

I have to assume that the EQ is not being sent to the same out port. Check the rack settings if it is in a rack, and drop down the arrow to check the output port if it is not in a rack. I think if you make a new object, it defers automatically now to create a route to the “Default” output device, so check which one of your audio ports has that designation applied.

You are most of the way there now, though! :smile:

Terry


#38

This is tricky for me. Is there a way to see what output cantabile is sending my voice through? So I can see exactly what output to change the EQ to?

Under the Preset/Destination header, the output of the EQ is called “Output Port - Main Speakers”.Is that correct?

If I click on “Output Port - Main Speakers” it gives me some options to choose. None of them stand out to me as being correct so I’ll not mess with them. The options are “None”, “Loopback - Main Microphone”, and “Output Port - Metronome”.

In fact let’s have another go at posting a screenshot.

Does that tell you anything useful?


#39

Hi,

Please re-post your screen shot with the input ports section expanded so we can see the routing.

Thanks

Dave


#40

OK here it is:


#41

Hi,

Add a route from your input ports to the plugin, that is why no processing.

set main microphone as source

set your eq plugin for destination

That will route mic input through eq to main speaker out. Hope this helps …

Dave