Arturia plugin activation

I have two identical Cantabile machines, and I’ve been trying to activate Arturia Prophet V on them both (the licence allows it to be installed on up to 5 machines). When I use Arturia Software Centre (ASC) to activate on machine A, the plugin becomes activated. However when I then run ASC on machine B, it claims it’s running on machine A, and reports that the plugin is already activated, and so doesn’t let me go ahead and actually activate on B. The plugin remains in demo mode, cutting out every minute. ASC clearly appears to be failing to tell the difference between my two machines, and so not allowing me to use two activations. Sounds like an Arturia bug to me.

I’ve contacted Arturia support, who respond quickly, but seem rather inept - they don’t appear to read the detail of what I report, and suggest basic stuff I’ve already told them I’ve tried. They asked me if I’d installed ASC on both machines…this is after I’d already sent them screenshots of ASC running on both machines.

Consequently I’m not sure I trust Arturia plugins for live use - don’t want to have a Prophet that goes silent every minute in a soundcheck in the middle of nowhere with no Internet connection…

Anyone else using these plugins on similar machines? Any problems? Any solutions?



I have been using Arturia for over 2 years now. Started out with Analog Lab, and upgraded to the V release. I was mostly impressed with Analog Lab, less impressed with V collection. I still use a few of them live, but they seem to be a bit quirky. If I pre-load a setlist, I usually have no problem except an occasional “no sound” event. If I load them on the fly, loading time is ridiculous. The V Collection has some really good points, but many of the instruments just do not make it for me (the B3 is terrible). I really believe you are right in diagnosing a bug. I have similar problems, but not with activation. The many boards I read have also been loaded with bug comments. I followed Torsten and Terry Britton suggestions on their use of Korg M1 plug. It seems to cover most of what I need and is not a cpu hog. Unfortunately, that was my only solution, and I, as you, fear the dreaded “bug” during performance.

Did you try unistalling and reloading on both machines. I know ASC can be quirky as well. It took me a few tries when I was activating.

Found this on Arturia site: Hello, about this yes you can now use your software on up to five machines.
To do this just install the softwares on another machine and activate it once more.

Thanks Corky. Yes, that’s exactly what I’ve been trying. After activating on one machine, the other won’t allow me to activate, thinking it’s already activated. I can then remove all activations and repeat the other way round, but it’ll never allow me to register the 2nd machine, even though it says I have 4 of 5 activations remaining.

Tried uninstalling and reinstalling on both - same result. Tried offline activation, same result. I really think ASC is convinced I’m just using one machine.

People are commenting on their forums that support has stopped responding to anything on the company forums since about January. What a shame!

I recently upgraded to the latest Arturia V Collection and have not noticed any issues yet. I am running on a single stand alone system though.

Mike Black

I have had the Prophet V activated on two machines for over a year. On the first machine I use it with C3, the other machine, just as the stand alone version. However, I don’t have the new version of the Prophet (V3) that just came out in May, but version 2. Maybe that is the difference.

  • Paul

Neil, are you running that plugin all by itself, or as a component of the entire V Collection 5 suite?

As I have the Suite, it only needs me to activate the suite, and it in turn activates all of the synths.

Also, from the “Gears” tab on the left of the ASC, make sure you are logged in as the correct machine.


Just by itself.

Anyway, it seems to be working ok now, although by luck more than anything I think. The Arturia support guys suggested I run the stand-alone version on both machines, and having done that, the plugin version appears to work from within Cantabile on both machines. The only worrying aspect is that ASC reports it only installed on 1 machine, with 4/5 activations remaining…so I’m half expecting it to stop working on one of my two machines at any time.

This is not a plugin I’m going to trust to rely on live right now, unfortunately.