Anyone using Guitar Rig 4 in C3

I encouraged a mate of mine to use C3 Solo to run his Guitar Rig 4 setup. I tested Solo here with GR5 and, of course, it works.
His setup is telling him that GR4 is not compatible with C3,
I ran his system with Reaper and C2 - both of which work.
Any ideas?


Hey Adrian…what is he running it on? GR4 is several yrs old now, and it only supported XP and Vista, which may, or may not be a problem. Just saying an upgrade to GR5 might help…dunno. I used GR5 on my Win 7 in C3 with no issues awhile back, till better things came along. So I just checked GR5 with the latest C3 Performer on Win7…no problem. Could changing the compatibility to XP on the plug make it work?



Hi Corky
I teamviewered into his system and tested C2 and Reaper - both of which run perfectly.
Up until now, he’s been using the same laptop to run GR4 as a stand-alone with no issue.
I’ve already suggested he uograde to G5 if no solution is forthcoming but … same computer … Cantabile 2, Reaper, both running.
In addition, he uses another W7 laptop. (Both Lenovo. Thinkpads BTW) to run his Cubase setup. He uses G4 in that all the time.

Yeah, that is weird. Understand though, C3 is a much different animal than C2 and Reaper. I may possibly have GR4 lurking in my W7 machine. If I do, I will test it. In the meantime, try my above suggestion about changing the compatibility to XP.

BTW Adrian, just my 2 cents…according to your friends strong ties with Guitar Rig, and other reasons involved, GR5 is already past 3 yrs old. Amp sims have progressed tremendously, and if money is an issue, there are some free plugs available that run very well with C3. I abandoned GR5 for greener pastures. I know it is a pain in the ass to lose all your favorite setups and start anew, but the newer plugs are freaking amazing, and the realism has become top notch within the last year or so.
I changed many of my original setups recently, just because of the better tones and lower CPU usage I am getting from the newer plugs. Again, just my 2 cents.



Solved It runs on his studio laptop. I should’ve checked that. It’s an installation issue on his live machine.

That’s great !! :sunglasses:

1 Like