Adding Pianoteq and TrackSpacer to piano VSTs for enhanced sympathetic resonance

Hi all. Though I’ve used Cantabile Performer for quite a few years I still consider myself a newbie as all I use it for basic creation of songs within set lists. My song routing is all very similar: MIDI controller->VST instrument->VST effect->Speakers.

I’ve seen some writeups and heard some demos of using Pianoteq (I own a license for the Pro version) with a flat velocity curve for adding sympathetic resonance to make Piano plugins more realistic. Since the Piano plugins have various degrees of resonance, using WavesFactory TrackSpacer seems to make sense for eliminating redundant harmonics. I get that the ‘source’ plugin (let’s say Keyscape as an example) is driving TrackSpacer, but how this happens in Cantabile is a mystery. I haven’t yet purchased a license for TrackSpacer until I’m comfortable with how ‘sidechain’ processing works in Cantabile routings.

Could someone please explain the concept behind setting up the routing in Cantabile? Again, all of my routings are currently sequential and it looks like this requires parallel routings.

BTW, I also have a license for the Pianoverb2 and it helps somewhat, but I’m not getting the ‘authentic’ acoustic sound I’m looking for with it. Hoping that Pianoteq might be a better solution.


Put more simply: is anyone using TrackSpacer, and how have you set up the routing in Cantabile?

I don’t know how to do this either, but I’ve seen the demos and am interested in what happens if you get it working. I don’t own TrackSpacer, but since nobody else has replied, I’ll take a guess at an answer…

If TrackSpacer has two audio inputs, one for the ‘main’ audio to be modified (e.g., Pianoteq) and one for the ‘sidechain’ (e.g., Keyscape), then I assume you just wire the audio-outs of Pianoteq and Keyscape to those two respective audio inputs. Then wire TrackSpacer’s audio output to Cantabile’s main audio output port. Assuming TrackSpacer only outputs the modified ‘main’ audio (not a mix of both inputs), I’d guess you need one more wire directly from Keyscape to the main audio output port. In theory, this would deliver Keyscape’s audio unaltered, mixed with Pianoteq’s audio down-gained to not muddy Keyscape’s frequencies. (Just my speculation from seeing the demo videos…)


Thanks Kevin. That totally makes sense to me. I think adding Pianoteq sympathetic resonance will really benefit some of my VSTs and I feel comfortable that I should be able to get this to work in Cantabile. I’ll probably pick up a license for TrackSpacer. Would love to get it during one of their sales but even at full price it’s not expensive.

Trackspacer is awesome when you’re mixing - I haven’t tried it for what you’re looking to do but it sounds plausible.

I did just try setting up a sidechain in Cantabile, and it wasn’t hard. Here’s what it looked like when I was done:


Originally Trackspacer only came up with the one input:


I right-clicked on “Input In” and selected “Port Settings”. I got a settings box with three tabs: General, Audio Ports, Information. I selected “Audio Ports”:


I clicked “Add” then “Stereo Input Port”. I Named it “Sidechain” and clicked “OK” and I had this:


I double-clicked “(unassigned)” next to “Left”, clicked “Add”, and then selected the channel “Sidechain - #1”:


Then I did the same thing with the right channel, assigning it to “Sidechain - #2”. Without going to the manual I don’t really know why this doesn’t default this way, but it’s what I did anyway. It wound up like this:


Make sure you always click “OK” - sometimes if you just click the “X” in the top right corner you lose the setting you just set. If you look at my first picture, I sent a janky piano plugin into the input and a drum plugin into the sidechain. When I played notes on the piano and then played the drums, with the “AMOUNT” in Trackspacer set to 100, the piano ducked completely to silence momentarily. If you want to hear the sidechained sound when the main sound is ducked, you need to also route the sidechained sound to the same output (so, one line from its output to sidechain, a second line from its output to “Main Speakers” or whatever your main out is named).

Perfect!! Thanks for taking the time to put together. Even I should be able to follow these instructions. There are several potential gotchas which you’ve pointed out which will eliminate trial and error for me and anyone else following your instructions. My guess is that, by dialing in TrackSpacer side chain compression, I should be able to achieve a realistic result.

I installed TrackSpacer and am trying to get Keyscape7 with Pianoteq sympathetic resonance to work, but having issues.

When I play, TrackSpacer is showing that it’s attenuating some of the frequencies. My assumption is that this is Pianoteq frequencies that are redundant with the Keyscape source.

However, I really don’t hear any difference between the ‘raw’ Keyscape sound and the sound with Pianoteq added, even when I boost the Pianoteq Symathetic Resonance setting.

More importantly, while playing I’m getting a crackling sound dropout every few seconds which doesn’t happen if I unenable the Pianoteq and Trackspacer routings (with just Keyspace to speakers enabled).

Here’s my routing diagram:

And the routing table:

Keyscape settings:



→ Any idea what the problem is and what I’m doing wrong?

After sending this, I tried just disabling Pianoteq, leaving Keyscape and TrackSpacer enabled, and the dropouts stopped. TrackSpacer display is still showing frequency response output for Keyscape with what I interpret to be dynamic equalization offsets.

Again, I don’t hear any difference in sound when I enable Pianoteq, other than the frequent Keyscape dropouts.

I tried reversing Keyscape and Pianoteq source input vs sidechain settings into TrackSpacer, but that didn’t work. Not sure what else to try. Help?

Hi @JonFromMaine,

To debug the no-improvement problem, I would disable the Keyscape-to-Speakers route so that I could hear only the Pianoteq contribution. You might discover that Trackspacer is killing too much of the sound. If so, you could dial down its “Amount”. You could also fiddle with the relative gains of the Keyscape-to-Speakers and Trackspacer-to-Speakers routes.

To debug the crackling, I would first pull up the Profiler (View menu) to see whether something is exceeding your cpu. Maybe Trackspacer isn’t keeping up. Another possibility is that audio is clipping somewhere along your routes, so I’d check the levels of everything as you play.


No sound at all when I disable the output from Keyscape to my speakers. I turned the main TrackSpacer knob all the way to the left but nothing.

Here’s what the input ports to TrackSpacer look like:

I get the feeling I’m doing something fundamentally wrong here.

Interestingly, with the directly route from Keyscape to Speakers disabled as shown in the screenprint, I’m still seeing the two frequency response curves in TrackSpacer moving when I play, but there is no sound output.

However, when I click SC Audition in TrackSpacer. I hear the Keyscape piano, with sound dropouts.

BTW- this is a fairly new Windows PC (Lenovo) with 32GB memory and I7 processor. CPU is consistently showing around 11% utilization and memory never goes over 50%. I don’t get dropouts with other plugins, including Keyscape or Pianoteq when played independently.

Also, when -both- directly Keyscape to Speaker -and- Pianoteq plugin are disabled, I get the Keyscape sound from the Trackspacer output with the two frequency graph lines active and with NO dropout, but only if SC Audition is enabled

Totally lost on this one.

I’d next route pianoteq directly to speakers and disable all other routes to speakers, just to be sure pianoteq is producing sound.

Regarding dropouts: Time load (which produces dropouts when exceeded) can go over 100% even when cpu load is low. I’ve gotten dropouts at as low as 10% cpu load when some unruly plugin pauses for longer than one audio cycle, slowing everything else in the pipeline. That’s why I always check Cantabile’s profiler to diagnose those.

As you were sending this I was in the process of sending both Keyscape and Pianoteq directly to the speakers, with the output from TrackSpacer disabled. I’m getting the dropouts, so the Trackspacer side chain issue is apparently not the cause. Also still not hearing any difference in sound or sympathetic harmonics when Pianoteq is disabled, just frequent crackly dropouts.

I am seeing the Time Load periodically going over 200% with the profiler. Not necessarily right when the dropout/crackle occurs, but close.

So now that I know the dropouts appear caused by excessive Time Load while Pianoteq is active, how do I fix it?

Pianoteq performance monitoring is also showing overloads. Doesn’t happen when I play any of the Pianoteq instruments by themselves.

I suppose I could try increasing my buffers in Motu4 settings. Never had to do this with any other combination of plugins though.

Motu4 Settings

I see that I’m getting load fluctuation warnings when playing Pianoteq standalone on this computer. I had Windows set to 'High Performance; and found that by changing it to ‘Balanced’ I actually had flatter load fluctuations reported by Pianoteq (though still warnigs about excessive fluctuations) and no dropouts running standalone or by itself in Cantabile. Unfortunately, I still can’t play both Keyscape and Pianoteq together without excessive Pianoteq load fluctuations causing sound dropouts. I bought this PC last summer and it’s running the latest Windows 11 updates. I have everything non-essential shut off. I tried increasing the buffers in Motu4 settings but for some reason it stays stuck on 256.
I’ll have to check the Modartt forum for people who have had success fixing this. For now, I’ll have to abandon this effort. Wondering if TrackSpacer has any other uses when just used as an EQ plugin in the chain…

Changed Windows back to ‘High Performance’ and not much difference from ‘Balanced’.

Wondering if there are some Cantabile performance settings that will help. Looks like this is where I adjust the buffers. Not sure if I can adjust these setting on a ‘per-song’ basis instead of globally.

It looks to me like your issues with dropouts are a separate problem not specific to one particular VST or song setup. If you haven’t thoroughly read it already, Brad’s glitch-free audio book is an incredibly useful resource.

Looking at your settings, I personally have had better luck with a higher buffer size (I’m comfortable with around 10ms latency), and an “Aggressive” Multi-processor Mode. I also find that enabling “64-bit audio” works better for me (but some others say the opposite). If you can’t change the buffer size in Cantabile, it’s probably because your audio drivers require that you do it in their control panel instead.

But glitches can come from other sources too. I notice that your Profiler histogram shows mostly low bars suddenly punctuated by super-high red bars. Sometimes that’s symptomatic of some other process or service interrupting Cantabile. Even on a fresh install of Windows there are many potential culprits. In the past, I’ve needed to find and uninstall other audio drivers that were auto-installed by Windows, disable or uninstall various Windows background services, etc. I also recently learned that turning Cantabile’s audio engine off then on again (using the power button in the upper-right corner) has a magical performance-improving effect on some machines. (On my current machine it reduces time-load by 70%!)

It’s hard to diagnose glitches from afar, but maybe some of these tips will help you.

Hi Kevin. Last night I systematically went through Brad’s Glitch Free document and applied nearly all the suggested changes (including Core Parking, Performance settings, USB sleep, turning off Windows built-in audio drivers and sounds, etc.). Now Ivory 3, which had been ok, is unplayable. The profiler is showing nearly constant 200% Time Loads when I’m not even playing and also when my MIDI controller is turned off!
I have a very large set (150) of Cantabile Songs representing all of the VST instruments I’ve acquired over the past 10 years. I’ve gone through a few and Pianoteq (played alone) which should be processor intensive, seems ok. I also tried some of my VSL pianos and they seemed ok.
This is a fairly recent acquired Windows 11 PC (Lenovo P360 Tiny) wiith a 12 Core I7, 32MB memory, two 2 TB internal SSDs where most of my samples, including Ivory Items, live. Task Manager never shows memory utilization over 50% and processor utilization is always under 15%.
I sent a note to Brad as I’m somewhat freaked out by this and don’t want to dig the whole any deeper changing system settings without some help!

Here’s what the Profiler looks like with Ivory3 loaded and my MIDI controller switched off (it looks like this with it on also, playing or not playing):

What is being loaded when there’s no MIDI input?

BTW- I’ve tried turning the Cantabile service and several Windows Restarts. I also tried changing the buffer size from 256 to 512. I haven’t tried ‘Agressive’ multi-processor mode. I believe I do have 64 bit audio set. I can’t imagine this had anything to do with installing TrackSpacer and creating the test song. I haven’t played Ivory 3 for about a month, so something else may have happened in the interim. I never previously noticed any dropouts with Ivory3 though very infrequently did with some of the VSL pianos. Now it’s become a major problem. I’m very careful with this PC and don’t run anything I don’t have to, especially when Cantabile is running.

Hi Jon,

I would be quite surprised if anything you’ve done so far (trying new VSTs, changing settings, etc.) has precipitated or exacerbated the problem you’re seeing. Whenever I see a Profiler graph like yours (low bars punctuated by red bars even when no midi is incoming), it has always been because some other process is interrupting Cantabile in the background. When a process does that, Cantabile blames the overhead on your VSTs because it only knows which VST was executing when the delay happened. It doesn’t know that the delay was caused by some other process interrupting and pausing the victim VST.

Diagnosing glitches from afar is hard, but I’d guess that probably something got introduced onto your PC over the past few weeks or months, and you just haven’t seen the effects until you started to aggressively test your setup recently. The problem process can easily be something that consumes almost no cpu, almost no memory, and is therefore hardly noticeable in Task Manager and the like. That’s because badly behaving processes can unfortunately lock up your system in ways that hardly affect anything other than realtime audio threads.

For example, Windows Update once installed updated networking drivers for my Dell laptop, and the updated drivers contained something that periodically saved PC health stats to a file. I didn’t notice any change for months, but then I started to see random VSTs being strangely slow, and many of my old racks became unusable. It was difficult to track down because the problem drivers didn’t appear prominently in Task Manager, system cpu load was always 8% or lower, memory load was negligible, and there was not even a particular application to uninstall or kill.

To find and fix problems like this, here’s what I do:

  • Never make lots of changes at once. Make one change, then test. Otherwise you’ll never know whether multiple changes had opposite effects, balanced each other out, etc.
  • Take a screen shot of all Windows services before doing anything to them, so that you can restore anything you break. I even make a backup image of my drive, so I can do a complete restore if I accidentally do something unrecoverable.
  • Proceed to disable services and kill processes one at a time to see whether any impact the Cantabile Profiler graph. Start with services that don’t sound essential, but I progress even to the important-sounding ones. Disabling an essential service or process might crash your PC, after which you’ll have to reboot and be sure to keep that one enabled.
  • Some processes/services resurrect themselves after being disabled/killed. I’ve found Process Lasso to be quite useful for auto-rekilling those during testing (and even during live performance when necessary).
  • If you have a full drive backup ready as a fallback, you can even go wild and start uninstalling everything until the problem disappears.

For me, this procedure has been more successful than using diagnostic utilities like LatencyMon and the like, which often seem to give me flawed analyses and advice.

Thanks for these useful insights Kevin. I’m going to dive back into this tomorrow and will try out Process Lasso. I’m really hoping there will be some diagnostic tool which will help with this instead of entirely using trial and error.

What you say makes sense about some misbehaving app, driver or server causing this. I didn’t consider that the Cantabile Profiler might be misrepresenting this as extended load times even without any MIDI input, but that is a reasonable explanation.

I haven’t changed all that much in the past month (until yesterday and today where I changed a lot between the ‘Glitch Free’ recommendations and some Motu 4 and Synthogy Ivory 3 updates). I do keep my Lenovo up to date via their app and have updated the firmware a couple of times recently, the most recent being yesterday after the problem was noticed. That’s going to be hard to for me to factor out if it’s causing this.

I did reach out to Brad and he gave me a couple of things to try, but I think he’s stymied on this as well.

I do have an archival C: Arcserver/Shadowprotect image I created a few months ago after most of my plugins were installed and working perfectly. If I had to, I suppose I could go back to that and then start reinstalling the pianos I’ve acquired since then. That’s a last resort though and I’m still hoping I can figure this out. It’s going to be a learning experience. Thankfully, I recently retired so have the time. I also have enough working pianos to practice on, though many of them are getting occasional dropouts I never heard before. That’s annoying but I can live with it for now.

Once I (hopefully) solve his, I’m going to back out some of Brad’s recommendations one by one, starting with the 100% utilization setting on the 12 cores, and seeing if that breaks it again. One of the things I like about this PC is it’s extremely quiet, but not so much anymore as the fans seem to be on most of the time now that all the cores are chugging along at full speed. -Jon