Adding 2nd instance of sonicprojects OP-X PRO-II hangs cantabile

Ive got the sonic projects OP-X PRO-II VST and added it to the rack which works fine. Then i tried adding a second instance to the same rack and the app just hangs for me. Is there anything i can do (eg. run in debug mode) to try and see whats causing cantabile to hang? thanks.

Hi Milsnips,

That plugin has been troublesome before for a few different reasons. I would recommend against stacking inside the rack, try putting the the 2 instances of OP-X into separate racks and see if that helps.


I can load multiple OP-X instances in one rack (using the latest 35xx build) and latest OP-X. But sometimes when adding the plugin, it causes Cantabile to cash. It’s random. It works 4 of 5 times.

1 Like

I seem to remember reading in the past that OP-X did this in a lot of DAWS.

Anyone tried the new BETA yet?

Which beta do you mean? I only see v1.2.5…

Oops! Sorry @FantomXR, I misspoke. My bad :flushed:

yeah its not something i can replicate, now it seems to be working. issue was happening when i was running C3 x86 with the v1.1 OP-X plugin. now i’ve switched to C3 x64 and i’m running latest v1.2.5 plugin, seems to be ok, although in C3 ui the preset dropdown list doesnt seem to load the list of sounds i can select. might be an issue with the latest x64 version plugin

I doubt putting second instance in a separate rack is likely to make much of a difference - it it does I say it’s just luck and a timing issue with the order things are processed.

In generally whenever I see issues with multiple instance my first reaction is a compatibility issue with Cantabile’s multi-core audio processing.


  1. Setting Cantabile’s multi-core mode to “compatible” instead of “aggressive” (in Options -> Audio engine).
  2. Disabling multi-core all together (Audio Threads -> “1 (disabled)”).

If neither of these help then you really need to take it up with the plugin developer.

Also, there’s a history of weirdness with OPX and Presets - see here.