3647: Custom button stopped working?


#1

I bound the first of the three custom buttons on a Linked Rack to open my plug-in’s GUI when pressed. This was working fine in 3646, but in 3647 the button turns blue, but nothing happens.


#2

Hi The_Elf, no trouble here with buttons on 3647 after update. Not sure what the glitch is if the binding is still intact.

Dave


#3

As far as I can see everything is as it was. I made a screen recording to show what’s happening:
Cantabile


#4

Thanks for the video, it shows the problem plainly. Have you tried disabling that binding and making a new one? Just wonder if creating new ones is still working …


#5

Hi!

How did you set a custom image for the button? :relaxed:

regards, Alexander


#6

Recreating the binding isn’t helping.

Wonder if the co-ordinates of the GUI window are being stored from my two-screen computer? I usually have the GUI open on the extended monitor. This is only not working on my one-screen laptop.


#7

Custom icons: Though they’re simply extended key codes, I use this page to find and copy the icons: Icons

Click on a symbol you like and it is copied into your copy buffer. Then paste where you’d like to put it.


#8

There’s also the Windows 10 mechanism for inserting Emojis: Win & . (period) - opens a pop-up with the common emoji range on Windows (searchable)


#9

Hа-ha …“Oh, yesterday came suddenly” :grin:
Thanks for the tip!
Didn’t think that way

kind regards


#10

Hi @The_Elf,

Just did some test here and seems to work fine. What happens if you go back to 3646 does it work again?

Is anyone else having this problem?

Brad


#11

I plugged my laptop into my TV and used it as a second monitor. Then I used the custom buttons and they worked; not opening on the TV screen, but on my laptop screen, just as normal. The TV remained blank.

When I unplugged from the TV everything was back to normal again. The custom button shortcut to the plug-in GUI is working perfectly.

Maybe something to do with my laptop’s graphics?

The thing that still puzzles me is the custom button remaining blue while I was having this problem - normally it only turns blue momentarily?


#12

The way the buttons act here is that when pressed they stay blue until another button or field is selected on the routes pane like the state or rack name.


#13

Then my money is still on the GUI being opened outside of the screen borders.