RESOLVED: ZebraHZ Crashes


My two systems are different versions of windows… I probably should have mentioned that.
My Win7 desktop + ZebraHZ = crash
My Win10 NUC + ZebraHZ = ok


Interesting. Both of my systems are WIN10,


Hi Guys,

I’ve been doing some testing here and confirm I’ve reproduced this crash but haven’t been able to figure out what Cantabile is doing to spook it (it doesn’t crash in other hosts for me either).

Here’s some things I noticed that might explain why different people are seeing different results:

  1. The crash only seems to happen immediately after loading a new instance of the plugin.
  2. It only crashes on selected certain presets. eg: for me it crashes if I load “Alternator Flute” or “An Enoding”, but doesn’t crash if I load “Cat Appeal”.
  3. After loading a preset that doesn’t crash, loading any other preset not longer crashes.
  4. Putting the plugin into a song, saving the song and then unloading and reloading the song also seems to clear the problem and any preset can then be successfully loaded.

I’d be interested to hear if this matches what others are seeing. Perhaps save/reload the song will work well enough as a work around until we can sort this out.

My gut feel at this stage is that something in ZebraHZ isn’t initialized quite correctly immediately after it’s first loaded. Why this is only a problem in Cantabile is hard to say, but some difference in memory layout, load order etc… could explain it.

Anyway, discussions with u-he continue and I’ll post back as I hear more information.



Hi, Brad

Thanks. I’ll try out your suggestions when I get five minutes and report back. You are correct re #1 in that for me the crash always occurred after selecting a preset.


This is exactly what I am seeing


I did some tests on both systems (Win7 desktop and Win10 NUC). Both show the same behavior as Brad described. So I must have happened to pick an initial preset that didn’t crash on the NUC before.

I’m not sure if this will help, but when I compare the folders on both system after one had crashed and the other had not, the file Presets\ZebraHZ\MIDI Programs\Midi.Bank.Cache.txt happens to be 0 bytes on the system that crashed while it is 73 bytes on the system that did not crash.

The contents of the good file:

// Cache file that speeds up loading of MIDI Banks

#Banks: up to date

So maybe it has something to due with MIDI Banks?



I can confirm that this is the exact same behaviour on both my NUC and my DAW machines, including the behaviour noted by Fesick about the Midi.Bank.Cache.txt file. Not sure what that means, but it might be a pointer for UH-E.

Another observation is that when I select “Cat Appeal” first, I get no sound despite the plugin showing that it is receiving MIDI activity. I need to select another preset and come back to it before I hear it. Quite a nice preset as well! :slight_smile:


Update: u-he have reproduced this and confirmed that its fixed for Zebra 2.8, release date unknown.


I think they are busy on turning their Pro-1 clone into a Pro-5 clone and getting that released, so I guess a Zebra update will come after that. But good to know it will be fixed, and until then we seem to have a work around :slight_smile:



Just asking if this was ever fixed? I can’t remember ever using ZebraHz in Cantabile after this?

I have just installed the latest version of ZebraHz, and it is working fine in Cubase 9.5, but it crashes instantly in Cantabile when you select any preset, including “Cat Appeal” mentioned above as being OK.


Just did some testing here and can confirm this problem still happens in the latest Zebra HZ 2.8. I’ve reached out to u-he to see if they have any additional information. (it was supposed to have been fixed in 2.8).


Hi, Brad

I’ve reported it to UH-E as well.

As I said, it seems to be all patches now?

Whereas last time you found a patch “Cat Appeal” that if you selected that first, the failure mode disappeared until you restarted.


Heard back from U-he - they can reproduce it and are looking into it.


Great. Let’s hope it gets fixed this time. :slight_smile:


Hi Derek,

Bladerunner is right. There can be odd Windows permissions issues for folders under the user’s profile - C:\Users(\AppData\(username)\Roaming\Modartt or C:\Program Files (and x86) or C:\Program Data and finally C:\Windows. Even though you are an administrative level user Windows can balk at a program you run when it attempts to access a file in these “special” folders. I’ve had situations where deleting the user profile and recreating it (yes lots of reinstalling) solved the issues meaning something had gone badly wrong most likely with permissions.


Update: a new build of ZebraHZ Is now available the fixes this issue.

You can get the download link by requesting your license by email here:

(When I asked why this only crashed in Cantabile, they said that had no idea and couldn’t believe it didn’t crash in every host).


Cool. Will check it out later and report back



Just been trying it out, and so far it has not crashed. So hopefully fixed, considering the last build was crashing instantly when you tried to select a preset.

So pleased this has been fixed :slight_smile: