No audio (at startup) with Windows 10 + MOTU

Hi @LAPianist

Thanks for reporting this. A couple of thoughts:

  1. Does this only happen immediately after starting windows - or at any time? Perhaps the hardware just isn’t ready in time.
  2. Instead of switching audio drivers, what if you just power cycle the audio engine (power button top right of Cantabile’s main window). That should have the same effect but more convenient.
  3. Is Cantabile displaying any error message or warning message boxes during startup. Sometimes these play a “Windows Sound” which can interfere with starting the audio driver. If so try waiting a few seconds after the message has appeared before dismissing it and see if this stops the problem from happening.

Aside from that, you could check (or send me) the debug log which is accesible via Tools -> Open Settings Folder and look in log.txt file.

Let us know how you go with it.

Brad

1 Like

Sounds like maybe another application is hogging the driver at boot?

1 Like

Hi Brad -

Thanks for the immediate and helpful thoughts.

Once it starts working, it never stops, so yes, this happens only when I turn on everything. I have been turning on all interfaces, waiting for all startup items, extensions, drivers, etc., but maybe I need to open the “MOTU Audio Console” first, to check to see that the interface is communicating properly, before starting Cantabile. I’ll try that.

I will power-cycle the audio engine instead of “changing” drivers and see how that works. It could very well be that either Windows isn’t ready when Cantabile starts, or some other program is grabbing the drivers and preventing audio from going to the interfaces.

Cantabile is not displaying any error messages or warning messages during startup, at least not audibly. I have Windows audio muted, though, so it may be happening but I’m not hearing it. Hmmm. But if that happens I will wait and then dismiss any dialog box that appears. Actually I have occasionally gotten warning messages from LoopBe about being careful not to create MIDI feedback loops, and even my iLok has started popping up messages warning me not to use on networks or across platforms simultaneously.

So, if these things don’t help, I’ll be getting the log file.

Thanks very much.

Here’s the log from a few days ago, when I gave up on Cantabile 3, thinking it wouldn’t solve my problem.

00000015 15 [09656:2]: ===============================================================
00000015 0 [09656:2]: Cantabile (x64) 3.0 build 3257 Starting…
00000015 0 [09656:2]: OS Version: Windows 10 Workstation 10.0 build 15063 (sp0.0) - (from Kernel32.dll)
00000015 0 [09656:2]: Number of virtual processors: 8
00000015 0 [09656:2]: Number of actual processor cores: 4
00000015 0 [09656:2]: Current local time: 21-07-2017 20:27:24.594
00000115 100 [09656:2]: Running as Cantabile Performer
00000237 122 [09656:2]: Loading settings
00000453 216 [09656:2]: Application starting
00000453 0 [09656:2]: Starting plugin scan (quick)
00000469 16 [09656:2]: Plugin cache contains 25 entries
00000469 0 [09656:2]: Found 25 files on VST 2 path
00000469 0 [09656:2]: Processing 25 VST 2 plugins
00000469 0 [09656:2]: Processing 0 VST 3 plugins
00000484 15 [09656:2]: Updating plugin database file…
00000516 32 [09656:2]: Plugin scan finished.
00000516 0 [09656:2]: Environment starting
00000516 0 [09656:2]: asio - Initialising on thread 9656…
00000538 22 [09656:2]: asio - Driver created OK
00000538 0 ! [09656:0]: asio - ASIO driver failed initialization
00000538 0 [09656:2]: asio - Releasing asio driver
00000585 47 ! [09656:1]: Failed to load or initialize audio driver. Check the device is connected and not in use by another application.

MOTU Audio ASIO

(Error code 13104)
00000585 0 [09656:2]: Engine stopping
00000585 0 [09656:2]: CoreEngine - Stopping
00000585 0 [09656:2]: CoreEngine - Parallel executor stopping
00000585 0 [09656:2]: Parallel Thread: exec:0 wakes:0 soft:0 hard:0 locks:0 lockrate:-nan(ind)
00000585 0 [09656:2]: CoreEngine - Parallel executor stopped
00000585 0 [09656:2]: CoreEngine - Stopping task pool
00000585 0 [09656:2]: CoreEngine - Stopped
00000585 0 [09656:2]: Heap Stats
00000585 0 [09656:2]: total allocations: 3
00000585 0 [09656:2]: total frees: 0
00000585 0 [09656:2]: created tanks: 1
00000585 0 [09656:2]: destroyed tanks: 0
00000585 0 [09656:2]: same thread frees: 0
00000585 0 [09656:2]: inter thread frees: 0
00000585 0 [09656:2]: allocs in tank: 3
00000585 0 [09656:2]: allocs from tank: 3
00000585 0 [09656:2]: allocs from free list: 0
00000585 0 [09656:2]: returned allocations: 0
00000585 0 [09656:2]: blocking allocs: 0
00000585 0 [09656:2]: blocking frees: 0
00000585 0 [09656:2]: context resets: 0
00000585 0 [09656:2]: blocking tank allocs: 0
00000585 0 [09656:2]: reserve tank claims: 0
00000585 0 [09656:2]: destroyed contexts: 0
00000585 0 [09656:2]: End heap stats
00000585 0 [09656:2]: Engine stopped
00004022 3437 [09656:2]: Application started
00004022 0 [09656:2]: Rack loading 'C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack’
00004022 0 [09656:2]: not found, loading…
00004060 38 [09656:2]: ref count 1
00004060 0 [09656:2]: 1 loaded racks, 0 active racks
00004060 0 [09656:2]: Rack loaded
00004060 0 [09656:2]: Activating rack C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack - ref count 1
00004060 0 [09656:2]: rack activating
00004060 0 [09656:2]: 1 loaded racks, 1 active racks
00004060 0 [09656:2]: Starting route operation: registering rack
00004060 0 [09656:2]: Finished committing re-route: +0=0, 0ms
00004060 0 [09656:2]: rack activated
00004060 0 [09656:2]: Rack activated
00004060 0 [09656:2]: Setting active set list 'NewSetList’
00004060 0 [09656:2]: Unloading rack C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack
00004060 0 [09656:2]: ref count 1
00004060 0 [09656:2]: Active set list set
00004060 0 [09656:2]: Song loading 'C:\Users\john\Documents\Pageant 2017\Pageant 2017 Laptop.cantabileSong’
00004060 0 [09656:2]: Rack loading 'C:\Users\john\Documents\Pageant 2017\Pageant 2017 Laptop.cantabileSong’
00004076 16 [09656:2]: not found, loading…
00004143 67 [09656:2]: ref count 1
00004144 1 [09656:2]: 2 loaded racks, 1 active racks
00004144 0 [09656:2]: Rack loaded
00004144 0 [09656:2]: Load operation starting
00004144 0 [09656:2]: Rack loading 'C:\Users\john\Documents\Pageant 2017\Pageant 2017 - Laptop.cantabileRack’
00004144 0 [09656:2]: not found, loading…
00004245 101 [09656:2]: ref count 1
00004245 0 [09656:2]: 3 loaded racks, 1 active racks
00004245 0 [09656:2]: Rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 (A)
00004245 0 [09656:2]: - ref count 1
00004245 0 [09656:2]: 4 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 (B)
00004245 0 [09656:2]: - ref count 1
00004245 0 [09656:2]: 5 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 ©
00004245 0 [09656:2]: - ref count 1
00004245 0 [09656:2]: 6 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt (D)
00004245 0 [09656:2]: - ref count 1
00004245 0 [09656:2]: 7 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading PlayVST
00004245 0 [09656:2]: - ref count 1
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Rack loading 'C:\Users\john\Documents\Pageant 2017\Pageant 2017 - Laptop.cantabileRack’
00004245 0 [09656:2]: ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 (A)
00004245 0 [09656:2]: - ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 (B)
00004245 0 [09656:2]: - ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt 5 ©
00004245 0 [09656:2]: - ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading Kontakt (D)
00004245 0 [09656:2]: - ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: Embedded rack loading PlayVST
00004245 0 [09656:2]: - ref count 2
00004245 0 [09656:2]: 8 loaded racks, 1 active racks
00004245 0 [09656:2]: Embedded rack loaded
00004245 0 [09656:2]: VST Plugin- Kontakt 5 (0x000000001EE9B040) - Loading C:\Program Files\VST Plugins\64 bit\Kontakt 5.dll (platform: 0002)
00005647 1402 ! [09656:1]: Unsupported audioMasterCanDo: receiveVstTimeInfo
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: reportConnectionChanges
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: acceptIOChanges
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: asyncProcessing
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: offline
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: supportShell
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: openFileSelector
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: editFile
00005647 0 ! [09656:1]: Unsupported audioMasterCanDo: closeFileSelector
00005795 148 ! [09656:1]: Unsupported audioMasterCanDo: NIMKPIVendorSpecificCallbacks
00007633 1838 [09656:2]: VST Plugin- Kontakt 5 (0x000000001F1A0A20) - Loading C:\Program Files\VST Plugins\64 bit\Kontakt 5.dll (platform: 0002)
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: receiveVstTimeInfo
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: reportConnectionChanges
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: acceptIOChanges
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: asyncProcessing
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: offline
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: supportShell
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: openFileSelector
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: editFile
00007633 0 ! [09656:1]: Unsupported audioMasterCanDo: closeFileSelector
00007658 25 ! [09656:1]: Unsupported audioMasterCanDo: NIMKPIVendorSpecificCallbacks
00013481 5823 [09656:2]: VST Plugin- Kontakt 5 (0x000000002A045590) - Loading C:\Program Files\VST Plugins\64 bit\Kontakt 5.dll (platform: 0002)
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: receiveVstTimeInfo
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: reportConnectionChanges
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: acceptIOChanges
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: asyncProcessing
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: offline
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: supportShell
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: openFileSelector
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: editFile
00013481 0 ! [09656:1]: Unsupported audioMasterCanDo: closeFileSelector
00013497 16 ! [09656:1]: Unsupported audioMasterCanDo: NIMKPIVendorSpecificCallbacks
00014813 1316 [09656:2]: VST Plugin- Kontakt 5 (0x000000001EE211A0) - Loading C:\Program Files\VST Plugins\64 bit\Kontakt 5.dll (platform: 0002)
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: receiveVstTimeInfo
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: reportConnectionChanges
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: acceptIOChanges
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: asyncProcessing
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: offline
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: supportShell
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: openFileSelector
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: editFile
00014813 0 ! [09656:1]: Unsupported audioMasterCanDo: closeFileSelector
00014839 26 ! [09656:1]: Unsupported audioMasterCanDo: NIMKPIVendorSpecificCallbacks
00016665 1826 [09656:2]: VST Plugin- play_VST_x64 (0x000000002A043BB0) - Loading C:\Program Files\VST Plugins\64 bit\play_VST_x64.dll (platform: 0002)
00018247 1582 [09656:2]: VST Plugin- play_VST_x64 (0x000000008675C740) - Loading C:\Program Files\VST Plugins\64 bit\play_VST_x64.dll (platform: 0002)
00018253 6 [09656:2]: Unloading rack C:\Users\john\Documents\Pageant 2017\Pageant 2017 - Laptop.cantabileRack
00018253 0 [09656:2]: ref count 1
00018253 0 [09656:2]: Unloading rack Kontakt 5 (A)
00018253 0 [09656:2]: ref count 1
00018253 0 [09656:2]: Unloading rack Kontakt 5 (B)
00018253 0 [09656:2]: ref count 1
00018253 0 [09656:2]: Unloading rack Kontakt 5 ©
00018253 0 [09656:2]: ref count 1
00018253 0 [09656:2]: Unloading rack Kontakt (D)
00018253 0 [09656:2]: ref count 1
00018253 0 [09656:2]: Unloading rack PlayVST
00018253 0 [09656:2]: ref count 1
00018255 2 [09656:2]: Load operation finished
00018255 0 [09656:2]: Setting active song 'Pageant 2017 Laptop’
00018255 0 [09656:2]: Starting route operation: switching songs
00018255 0 [09656:2]: Activating rack C:\Users\john\Documents\Pageant 2017\Pageant 2017 Laptop.cantabileSong - ref count 1
00018256 1 [09656:2]: rack activating
00018256 0 [09656:2]: 8 loaded racks, 2 active racks
00018256 0 [09656:2]: Nested route operation: registering rack
00018256 0 [09656:2]: rack activated
00018256 0 [09656:2]: Rack activated
00018271 15 [09656:2]: Finished committing re-route: +0=0, 1ms
00018271 0 [09656:2]: Active song set
00018271 0 [09656:2]: Song loaded
00123558 105287 [09656:2]: File song ‘Pageant 2017 Laptop’ modified by PluginSolo
00180703 57145 [09656:2]: File rack ‘Pageant 2017 - Laptop’ modified by Route
00233856 53153 [09656:2]: WASAPI: Creating device enumerator
00233857 1 [09656:2]: WASAPI: Getting endpoints
00233858 1 [09656:2]: WASAPI: Devices found: 1
00233858 0 [09656:2]: WASAPI: Found WASAPI render device #0: {0.0.0.00000000}.{ef4b6251-903e-4fb2-9f97-770c841c0948}
00233858 0 [09656:2]: WASAPI: - friendly name: Speakers / Headphones (Realtek Audio)
00233858 0 [09656:2]: asio - Initialising on thread 9656…
00233858 0 [09656:2]: asio - Driver created OK
00233858 0 ! [09656:0]: asio - ASIO driver failed initialization
00233858 0 [09656:2]: asio - Releasing asio driver
00233880 22 ! [09656:1]: Failed to load or initialize audio driver. Check the device is connected and not in use by another application.

MOTU Audio ASIO

(Error code 13104)
00244824 10944 [09656:2]: Saving settings
00244929 105 [09656:2]: Starting route operation: options changed
00244929 0 [09656:2]: Finished committing re-route: +0=0, 0ms
00251673 6744 [09656:2]: File song ‘Pageant 2017 Laptop’ modify flag cleared
00251673 0 [09656:2]: Saving settings
00251711 38 [09656:2]: Setting active song 'None’
00251711 0 [09656:2]: Starting route operation: switching songs
00251712 1 [09656:2]: Deactivating rack C:\Users\john\Documents\Pageant 2017\Pageant 2017 Laptop.cantabileSong - ref count 0
00251713 1 [09656:2]: rack deactivating
00251713 0 [09656:2]: 8 loaded racks, 1 active racks
00251713 0 [09656:2]: Nested route operation: revoking rack
00251713 0 [09656:2]: rack deactivated
00251713 0 [09656:2]: Rack deactivated
00251713 0 [09656:2]: Finished committing re-route: +0=0, 0ms
00251713 0 [09656:2]: Unloading rack C:\Users\john\Documents\Pageant 2017\Pageant 2017 Laptop.cantabileSong
00251713 0 [09656:2]: ref count 0
00251713 0 [09656:2]: unloading
00251713 0 [09656:2]: 7 loaded racks, 1 active racks
00251713 0 [09656:2]: Unloading rack C:\Users\john\Documents\Pageant 2017\Pageant 2017 - Laptop.cantabileRack
00251713 0 [09656:2]: ref count 0
00251713 0 [09656:2]: unloading
00251713 0 [09656:2]: 6 loaded racks, 1 active racks
00252440 727 [09656:2]: File rack ‘Pageant 2017 - Laptop’ modify flag cleared
00252440 0 [09656:2]: Unloading rack Kontakt 5 (A)
00252440 0 [09656:2]: ref count 0
00252440 0 [09656:2]: unloading
00252440 0 [09656:2]: 5 loaded racks, 1 active racks
00252468 28 [09656:2]: VST Plugin- Kontakt 5 (0x000000001EE9B040) - Closed
00252468 0 [09656:2]: Rack unloaded
00252468 0 [09656:2]: Unloading rack Kontakt 5 (B)
00252468 0 [09656:2]: ref count 0
00252468 0 [09656:2]: unloading
00252468 0 [09656:2]: 4 loaded racks, 1 active racks
00252587 119 [09656:2]: VST Plugin- Kontakt 5 (0x000000001F1A0A20) - Closed
00252587 0 [09656:2]: Rack unloaded
00252588 1 [09656:2]: Unloading rack Kontakt 5 ©
00252588 0 [09656:2]: ref count 0
00252588 0 [09656:2]: unloading
00252588 0 [09656:2]: 3 loaded racks, 1 active racks
00252694 106 [09656:2]: VST Plugin- Kontakt 5 (0x000000002A045590) - Closed
00252694 0 [09656:2]: Rack unloaded
00252694 0 [09656:2]: Unloading rack Kontakt (D)
00252694 0 [09656:2]: ref count 0
00252694 0 [09656:2]: unloading
00252694 0 [09656:2]: 2 loaded racks, 1 active racks
00254041 1347 [09656:2]: VST Plugin- Kontakt 5 (0x000000001EE211A0) - Closed
00254042 1 [09656:2]: Rack unloaded
00254042 0 [09656:2]: Unloading rack PlayVST
00254042 0 [09656:2]: ref count 0
00254042 0 [09656:2]: unloading
00254042 0 [09656:2]: 1 loaded racks, 1 active racks
00254206 164 [09656:2]: VST Plugin- play_VST_x64 (0x000000002A043BB0) - Closed
00254355 149 [09656:2]: VST Plugin- play_VST_x64 (0x000000008675C740) - Closed
00254355 0 [09656:2]: Rack unloaded
00254355 0 [09656:2]: Rack unloaded
00254355 0 [09656:2]: Rack unloaded
00254355 0 [09656:2]: Active song set
00254355 0 [09656:2]: Setting active set list 'none’
00254355 0 [09656:2]: Unloading rack C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack
00254355 0 [09656:2]: ref count 1
00254355 0 [09656:2]: Active set list set
00254355 0 [09656:2]: Application stopping
00254355 0 [09656:2]: Application stopped
00254374 19 [09656:2]: Window closed, client disposed
00254374 0 [09656:2]: Application closing
00254374 0 [09656:2]: Deactivating rack C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack - ref count 0
00254374 0 [09656:2]: rack deactivating
00254374 0 [09656:2]: 1 loaded racks, 0 active racks
00254374 0 [09656:2]: Starting route operation: revoking rack
00254374 0 [09656:2]: Finished committing re-route: +0=0, 0ms
00254374 0 [09656:2]: rack deactivated
00254374 0 [09656:2]: Rack deactivated
00254374 0 [09656:2]: Unloading rack C:\Users\john\AppData\Local\Topten Software\Cantabile 3.0 (x64)\Background Rack.cantabileRack
00254374 0 [09656:2]: ref count 0
00254374 0 [09656:2]: unloading
00254374 0 [09656:2]: 0 loaded racks, 0 active racks
00254374 0 [09656:2]: Rack unloaded
00254374 0 [09656:2]: Application closed
00254374 0 [09656:2]: Cantabile signing off.

I can’t help much, only to say that I saw this behaviour begin after updating to the latest stable version around four weeks ago. Before that I’d not had this happen. I usually shut down Cantabile and restart it, then it’s fine.

1 Like

Obviously this is a huge red flag :slight_smile:

Looks to me like the driver and/or the hardware has got itself into a knot and doesn’t want to start. That error code basically means that when Cantabile is asking the driver to initialize itself, the driver is failing (for reasons unknown).

I can’t really see how this can be an issue relating to Cantabile (since the log shows Cantabile has just started when this fails) unless there was a previous unclean shutdown of Cantabile and the driver/hardware was left in a bad state, or Cantabile is still running as a different process in the background somewhere - you could check this in task manager.

Best bet would be to a) make sure you’ve got the latest drivers from MOTU installed (particularly if they’ve released new versions for Win10) and b) contact there support and ask them what might cause the error. Feel free to pass on my contact details if you like - happy to discuss with them the details of what’s going wrong if they need it.

Brad

1 Like

Hi, this may be a red herring, but I have had problems with Cantabile 2 and a Focusrite Saffire USB interface when I had the interface plugged in a USB 3 port. For some reason Cantabile would not shut down cleanly (had to kill the Cantabile process in Task Manager even though the UI had disappeared). If I plugged the same interface into a USB 2 port on the laptop then all was fine. I ended up labelling the ports on the laptop that the various devices had to be plugged into!

I also have a MOTU MIDI Express that does not like USB 3, despite USB 3 being supposedly backwards compatible. I’d get all sorts of hanging notes as a result. Clean as a whistle on a USB2 port.

Another recent issue I have had migrating to a new Focusrite Scarlett interface is current draw was greater than the old Saffire, which the laptop could not supply, so I have had to put a powered hub between them.

Not sure if your problem could be due to any of these issues, but well worth checking out to see what type of port (USB 2 or 3) you are currently plugged into and trying the alternative if you can.

2 Likes

Thank you all for the help.

Last night before my show it took 30 minutes for me to get Cantabile audio working. I tried stopping the audio engine several times, then switching among drivers, then re-starting Cantabile, then re-starting the computer. As usual, it finally worked, with no glitches. But starting audio in Cantabile is becoming quite a frightening and burdensome daily exercise.

I do have the latest MOTU drivers and firmware updates.

This experience makes me think that something is hogging my MOTU ASIO audio driver and preventing Cantabile from accessing it. Is it possibly “Cortana” (which I don’t need)?

Does Cantabile support WaveRT ? If it does, then I will enable it on the MOTU driver, and possibly prevent this problem.

Last night I disabled a few things in Task Manager before successfully starting, but I’m not sure what is needed. For example, is it absolutely necessary to disable audio drivers that you are not using, such as Realtek HD Audio Manager or other support apps like Waves MaxxAudio Service Application (which apparently runs on Dell computers by default)? Or just ignore them? What about “HD Audio Background Process”? (I’m on a Core i7 7th generation chip with SSD and 32 GB RAM, so I don’t lack power, plus I can distinguish among audio drivers when I’m not plugged into the MOTU)

One interesting phenomenon that a friend discovered is that Google Chrome with YouTube will hog the audio drivers of any PC, and definitely messes up Finale audio. Of course I never use Chrome before Cantabile.

Just now I went through this Windows 10 optimization guide again: https://support.focusrite.com/hc/en-gb/articles/207355205-Optimising-your-PC-for-Audio-on-Windows-10 I disabled many startup items and all Windows background apps.

Hopefully disabling some of those things (plus possibly enabling WaveRT) will work. I suppose I should check for FAQs here regarding Windows 10 optimization as well.

In case anyone hasn’t seen this, check out https://www.cantabilesoftware.com/glitchfree/

1 Like

Shouldn’t be Cortana (which as far as I know is impossible to fully disable). Are there other audio apps on the machine, or just Cantibile?

1 Like

Doing lots of things with the MOTU drivers can leave a ton of trashed installs behind. Take a look at this article and see if you have this situation going on with your MOTU machine:

Terry

1 Like

I had issues with my MOTU UltraLite mk3 as well - usually needed one or more power-cycles of the audio engine to get going, with sporadic other issues.

So I’ve gone back to my RME Babyface plus an ADAT I/O; no more issues here…

Looks like MOTU interfaces are a bit tricky…

Cheers,

Torsten

I too use a MOTU Ultralite Mk3, and occasionally it doesn’t allow Cantabile’s audio engine to start. I can almost always cure it by disconnecting its USB cable and reconnecting, and then toggling Cantabile’s audio engine button.

Neil

1 Like

Thankfully, both my Ultralite mk3 hybrid and 828 mk3 hybrid have been rock-steady for many months now, but I went through quite a few bad moments with each. (Even tried “Fry-your-wire”) - USB is most stable, and I turned off (disabled) the “MOTU Audio Wave” drivers entirely and use Voicemeeter to interface my system sounds and players with the MOTU ASIO boxes now, as those MOTU drivers want to change the internal sample rate of the box itself every time a new sample rate comes its way, causing untold mayhem as a result. Never a problem since doing that!

Terry

1 Like

Just to clarify, does this mean you have Voicemeeter ports set up in Cantabile and route your stuff to that, instead of directly to MOTU ports?

Neil

Well, that depends upon “When”.

When making videos on the same machine or streaming via Hangouts or Skype, I port Cantabile’s audio all through Voicemeeter’s ASIO input (that is, I select Voicemeeter as the ASIO interface device).

When making videos or streaming to YouTube via OBS from the dedicated computer for that, I send the Cantabile audio out to the recording computer from Cantabile directly. System audio on the main machine comes in from Voicemeeter as below if I’m using system audio for sound effects, background music, including hangout or skype audio, etc. Zero sample rate issues.

All other times, I only “feed” system audio into Cantabile via Voicemeeter, with Cantabile set to use the MOTU ASIO device as the audio interface directly. I use Voicemeeter in this instance, for example, to pipe the system audio (my media players, YouTube, etc.) into Cantabile as I use Cantabile as the host for my IK Multimedia ARC2 room correction plugin. (It sits at the end of my “Processing Rack” final output rack if I’m monitoring using speakers.) Voicemeeter allows you to send to the inputs of any ASIO device you have in A1 directly as the A2 or A3 outputs (Voicemeeter Pro). I send A2 to Voicemeeter’s MOTU ASIO 15+16 (the otherwise unused ADAT optical port looped back to itself on the 828 so it can appear as an input) to port through the MOTU and into Cantabile. (A1 always uses the first output, typically Main Out.)

Anyway, just to clarify (which I haven’t done yet), usually Cantabile goes direct to the MOTU ASIO. System audio is sent to Cantabile from Voicemeeter via that ADAT loopback. (You can do the same loopback trick using S/PDIF to generate inputs from outputs.)

Voicemeeter is VERY flexible, and does the sample rate conversion very well out to the MOTU so the MOTU can stay at one sample rate setting and never get “confused”.

This sure needs a video or two!!!

Terry

2 Likes

Thanks Terry, that’s really good information to know. I use Voicemeeter for various things, but haven’t yet settled on a solid process for using it that I’m happy with, so this is really interesting stuff.

Neil

1 Like

I’ve updated the topic test to include “MOTU” to hopefully help others with similar problems find this post - great info guys.

2 Likes

I’d suggest to try out the ASIO4All driver instead of the original MOTU driver. I had a lot problems with the MOTU driver. Also the ASIO4All driver is much faster in my setup as the original. I was not able to get to a playable latency with it.

No. Just one install. Brand new computer. And BTW I bought the computer thinking that it would solve the exact problem I’m having. So now I’m going to try a Focusrite interface. Thanks for thinking of this, though.

1 Like