MIDI volume control


#21

Thanks Neil.

Naming can be tricky… I’ll think about it more when I get to implementing it.

Brad


#22

FWIW, in my setup (well with C2) I use the Korg NanoKontrol, with the sliders mapped to CC7, and assigned by channel, to match the channel assigned to the VSTi. This way I never have to worry about volumes in a live situation as I already have a little “mini” mixer in the signal path. I assign the rotary knobs to pan (10)

I can only use 8 channels (only eight sliders and knobs) but I find in the main this is plenty for each session :slight_smile:


#23

Thanks Pax-eterna! Do you do all your volume setting “live” with the NanoKontrol, or do you have any pre-programmed levels for different songs/parts?


#24

Neil I get the balance I want when I set up the song - sometimes with a backing track sometimes not…I find that often what I “hear” in the studio is a bit different to the live sound, so it gives me the advantage of fixing dynamically. There are a few other buttons and such that can be programmed with anything so it has the capability of controlling quite a lot in VSTi’s in Cantabile. I just use it for volume and pan hahaha!


#25

Since there isn’t a volume parameter in FreeG to map to, I assume you are referring to the Fade or Trim controls. Is that right? Although I’ve set up a binding to control the Fade function, it doesn’t work. Mapping my slider to the Trim function, however, does work.


#26

Nope, it’s “1: Gain” - sorry for the confusion around “volume” - wasn’t at my production machine when I wrote the post.

Note: you need to use the numbered parameter to address the plugin’s internal parameter, NOT the Gain parameter in the list above. The un-numbered stuff are Cantabile settings around the plugin - numbered parameters are the plugin’s own.

Cheers,

Torsten


#27

I see, and 1:Gain = Fader control


#28

correct! You’ll see this in the GUI when the fader moves…


#29

Yep, when controlling a rack’s volume with FreeG, the volume changes as I move the fader. But there’s no indication of audio input on the meter. Why?


#30

Hmm, funny - I see incoming audio on the FreeG meter. Not sure what’s going on in your setup…


#31

Thank you, @Torsten… You just saved me a metric ton of time! I was searching for a way to bind my MIDI faders to set a max-level “ceiling” for each plugin in a song, but I then wanted a way to bind my expression pedal to a plugin’s gain while still having that “ceiling”. Terrible explanation on my part, but your put-everything-in-a-rack idea was brilliant. For this particular song, I put my strings VST in a rack, put my pads VST in another rack, bound faders to each rack’s overall gain for leveling, and then I bound my expression pedal to the strings VST’s gain inside its rack. => Exactly what I wanted. :slight_smile:

I’ve just lately discovered the power of racks for song/plugin organization, and for this kind of fine-grain control with bindings. @brad, I know I say this a lot, but great product. The thought you’ve put into it, and the way you respond to community feedback really shows in the capabilities of Cantabile.


#32

Torsten,

regarding FreeG, I have routed a midi input to FreeG, and then from FreeG to Halion Sonic 3 (hoping to set up filtering for volume by MIDI channel) - but no meters are moving. Have I done something wrong?


#33

Sending MIDI to FreeG will not do anything - FreeG is an audio plugin. You need to route your MIDI to HalionSonic to create sound, then route the audio output from HalionSonic through FreeG to modify the volume