Fishman Triple Play Routing in Cantabile


#1

I’m testing out a Triple Play with Cantabile and all was working well until I pre-loaded the set in performer. If anyone is already running a Triple Play, a description of the Cantabile Routing would be helpful.

At this time, I have the Triple Play as a MIDI input port, then “drag a routing line” to the Triple Play Plugin at the Top (midi in). In the Triple Play Plugin, the various VSTi are loaded, then the Stereo out is directed to the main audio output. No problem at all controlling sounds.

If anyone is not familiar with a Triple Play, it has the ability to send individual MIDI channels 1-6 to the soft synths, so the high e-string (midi channel 1) could run Kontakt samples, the b-string (midi channel 2) could run East-West Violin, etc. OR, all the guitar strings will be on MIDI channel 1 to play polyphonic sounds on a Kontakt Piano for example. Different songs require different modes: The POLY mode or the MONO mode.

Here is the issue. When the sets are Pre-loaded, the Fishman becomes stuck in the MIDI Mode at the time of the Pre-load. If the set is not Pre-loaded, the Fishman swaps modes perfectly (but it takes a lot of time to load each song). Pre-loading the set makes the system non-workable.

My first thought is why do I have to route the Fishman MIDI input back to the Fishman Plugin on the Cantabile Routing page? It seems like the Fishman should receive it’s own MIDI without going through Cantabile. The Fishman is showing each string as plucked, but no MIDI gets to the VSTi until the Fishman MIDI IN is routed to the Fishman.

Maybe I’m the problem and someone has a better way to MIDI route? Also, maybe Fishman and Cantabile don’t play well together in Pre-load and I just need to not Pre-load. I’ll keep tweaking and any suggestions would be appreciated!

I’m starting to think that the the triple play should only be a MIDI device and route directly to the individual VSTi and not use the triple ply as a VSTi shell.


#2

As I am tweaking, I noticed that when a different song is loaded, the Fishman plugin states “Used in another Track” with a hot button titled “USE HERE.” If USE HERE is activated, the problems go away. Maybe issue is not being stuck in POLY or MONO midi mode when pre-loaded, but the Fishman being pre-loaded in every song and not being released? Once the fishman is “USE HERE” the mode changes as expected.

I’m searching for “Fishman ‘used in another rack’” and nothing is on the web.


#3

Hi

I use FTP exclusively for MIDI control of VSTs and do NOT use the shell. I simply use it as a MIDI input device. This set up works fine. Its the same as using a MIDI keyboard controller except of course it’s a guitar :blush:


#4

Thanks. That makes sense. I’ll leave the FTP in POLY mode all the time and combine string MIDI channels as/if needed with the Cantabile MIDI filters before routing to VST. The only problem might be FTP states “all our provided plugins are optimized for FTP” so I hope they behave as well outside of the FTP shell as inside.


#5

Fortunately, I Don’t use any of the vsts packaged with FTP so that’s not a concern for me. I also don’t use any of the keyboard splits or individual string routing. If I did, I may have had to look more closely at using FTP as a VST. So I’m happy with it as a simple guitar MIDI controller.


#6

Hi I’ve been using FTP with Line6 Variax for a long time and started using Cantabile recently since they introduced diagrams. It works fine with the Midi input device to the FTP Vst. The only problem I was having was with the Time Load but recent updates seem to have improved this. Not sure what the Poly/Mono problem is as FTP usually looks after that.


#7

I set up one of the included Fishman VST as a stand-alone VST and routed the FTP midi out to the VST midi in and there are sounds so the routing works. The first Cantabile test load had the FTP MIDI from FTP as poly (that means all strings are on channel 1). I shutdown Cantabile, started FTP alone, and changed to Mono (High E = Midi channel 1, B = Channel 2, etc). That FTP setup was working when Cantabile was restarted. So, each guitar string has a separate midi channel (1-6). Hopefully, after a reboot that FTP status will remains as last-load.

Bigger issue is lots of “midi-misfires” (maybe my sloppy playing!) such as additional notes or differences that were not there with using the FTP VST Shell. I started digging around with the Cantabile Midi Monitor and there is another channel (Midi 8) that is also sending controllers 29, 30, 31, 61, 63, 29 (fine) and 31 (fine). Not sure what that is, but it must be additional information sent to the Triple play program to catch/incorporate guitar nuances? From what I can tell, Midi CH8 controllers pass which string was plucked and individual string bends. What FTP does with info, I have no idea.

I’ll keep playing because maybe I’m missing something, but this loss of the midi channel 8 from the FTP pickup concerns me. Once again, issue with FTP and Cantabile is only when pre-loading a set list. FTP shell appears to be only pre-loadable in the first song loaded and will not release for another song without manual intervention. When not pre-loading, there is no “FTP sticking.” Worst case is I don’t pre-load and move on with making music…