Feedback computer config


#17

Just ran it on two of my main machines (figures from Cantabile profiler):

  • Live Cube (Core i5 9600K @ 3.7 GHz) runs this at around 31.4 % average, 35% max)
  • My studio PC (Core i7 7700K @4.2 GHz) is at 32.1% average, ca. 38-40% max)

Cheers,

Torsten


#18

Torsten

Just to know, both your PCs are desktop, right? Frequencies are too high for a mobile processor. My desktop music PC is dead, so I’ll test only the laptop. I’m on my way…


#19

Trouble: I see five Tyrrel all with unconnected midi in. In binding page i have 15 “missing target”. I connected all midi in to my keyboard, but I don’t know the trigger. A single note? A chord? I am sure there is something very important that I have not understood. @Torsten feel free to blame me, but please enlight this nightly keyboard player. It’s 3:20AM here, My brain is working 5%


#20

Excellent!!!

I make the test! But the cantabile song you post won’t work for everyone… (different folders…) That’s not a problem. let install it the way we want.

I think we should all put 5 instances of Tyrell, prest 1, make a chord with 3 notes and hold it 10 second and see what’s going on. Note the result A

Play the same chord several for 10 seconds but hit it each second. Note it B

then stress it and play fast all the notes possible and note the result C.

We have to set the same audio parameters.
I put agressive mode beacause it really helps to see if the pc is strong or not.

Do you agree?


#22

Very useful @Torsten

My results
Dell Inspiron 5559, Intel Core i7-6500U 2.5 Ghz runs at 50.0% average, 68% max

In general I am ok also for live performing, even with Keyscape and Omnipshere patches. But my setups are fairly simple, as I am in a 5-person band. But apparently I can improve my system almost a factor 2

I am planning to update my laptop system next year. Will get back to you and this forum for best specs to run Cantabile.


#23

Surprising my old pro 2 seems to be not that bad if I play normally…
Really put the same audio parameters:)


#24

Have you actually installed Tyrell in the correct plugins directory? The bindings should point to the five Tyrell plugins (first three to Tyrell 1, next 3 to Tyrell 2, and so on). If you have “mising target”, then something may be going wrong loading Tyrell into the song. Can you try if you can manually set the targets of the bindings to the five instances of Tyrell?

What these bindings do is simple send an E-major chord (e-g#-b) in the middle octave to all five Tyrell instances. So you could connect your MIDI input to all five instances and play (and hold) this chord - should give the same result.

Anyone else with these issues?


#25

This is what the bindings page should look like:

I use the 64 bit version of Tyrell - maybe that contributes to the issues?

All five instances use the preset “PV - JX Choir”

Audio settings are default from installation (except limiter switched off)
grafik

Cheers,

Torsten


#26

Yes, my studio PC is a full-size tower PC, the Live Cube is a small form factor (2 liters) ASRock Mini-PC running a desktop processor.


#27

Hey your live cube has better results?!


Is it something like that?

https://www.mifcom.de/gaming-cube-i5-9600k-gtx-1660-ti-ssd-id5558


#28

Here some more data:

  • my current live laptop (Core i7 9750H @ 2.6 GHz): average around 34.5% , max around 36%
  • my old live laptop (Core i7 4720HQ @ 2.6 GHz) average around 43.3%, Max ca. 50%

#29

it’s even smaller: the ASRock Deskmini 310:


#30

Now here’s an interesting discovery:

  • I start Cantabile, set audio engine to “Null Audio”
  • I load the song “Perftest” - Time load settles at around 32% average on my studio PC
  • now I stop the audio engine (on/off switch) - time load (obviously) goes down to zero
  • now I turn the audio engine back on - bindings fire again and start playback (since Song->onLoad also fires on turning the audio engine back on)
  • now the time load is only at around 14% average and 20% maximum
  • same on my old live laptop - average drops from 43% to about 19%
  • no such effect on my new live laptop - average stays around 34% after engine cycling
  • also no effect from engine cycling on my live cube

@brad: any idea what’s going on here? Maybe you can reproduce this?

Cheers,

Torsten


#31

Hi,
Sorry for the late I was “on the road”

My studio PC is "core I7 - 7820X 3.6 GHz, memory access : 3600 Mhz

Time load : 53% - Average 38,6 %
But I wonder if it is not more relevante to observe the CPU load dedicated to Cantabile with the cantabile ‘profiler’
CPU Load (Cantabile) : 1.9 %

What do you think of that ? There is a huge difference between the "time load and the CPU load, what is the more important ?

My gig configuration will be largely under my studio configuration (certainly i5 6th generation) …

Next I will try on my professional laptop (just for the test) it has a Xeon
Pierre


#32

I have now used this song on four different machines with Tyrell installed in different VST directories: C:\Vstplugins, C:\Program Files\VstPlugins, C:\Program Files\Steinberg\VstPlugins

It loaded and started flawlessly on all four machines - just out of interest: where is the Tyrell dll installed on your machine? And: are you using the 32 bit or 64 bit version of Cantabile? I’m using 64 bit on all machines.

Cheers,

Torsten


#33

Time load is the more relevant metric for using Cantabile live - it measures how much time it takes Cantabile to fill the audio buffer compared to the time to play the buffer. Once time load crosses above 100% you start getting drop-outs, irrespective of overall CPU load.

See @brad’s explanation here.


#34

I played manually the E-major. Here is the result:

  • 43.2% average. 45.3 max (i7-4810MQ@2.8GHz) Null Audio/256
  • 42.1% average. 44% max. same processor. Audio Board ASIO/256

I’m unable to reproduce your “19%” conundrum.

Paolo


#35

Hey
I expreminented the same thing…
Strange.
Stop and reopen and you win some extra %… well I saw that too.


#36

I tried Torsten’s “perftest” song file, with null audio @ 44.1 / 256

Average time load - 68.0%
Maximum time load - 89.4%

I’m using a 10 year old 1st generation i5-750 @ 2.67GHz 4 core desktop.
Ya I know it’s antiquated, but has been reliable. And actually survived (barely) this test. :slight_smile:

I did not experience the load % changing after stopping and starting the audio engine like Torsten experienced.


#38

I got better performances in aggressive mode. Not so much as you. About 8%