Crackling issues Keyscape - only in cantabile

I’m assuming that your drive is a fast SSD? The large number of samples that Keyscape uses demand a fast drive. (Also did you check the settings within Keyscape? Not on my music PC at the moment, so I can’t remember the exact settings.)

Apart from the GPU setting that we discussed in another thread, then an obvious candidate is CPU throttling, so make sure that you are on the High Performance power plan (or similar settings).

@TorstenH ; yes I am on hi performance plan; all Windows settings tweaked for audio
@Roland_Robertson: yes, fast SSD, yes played with the Keyscape settings - makes no difference
@Torsten; yes, played with all Cantabile multiprocessor settings, makes no difference

I ran the performance profiler and it’s ridiculous - seems related to the damper pedal - when I release that, Keyscape goes through the roof. :frowning:

Guess I’ll have to repurpose that machine for other duties c’se I am out of things to try.

I am getting suspicious…
New machines with faster processors seem to behave worse than older ones.
It is connected to some Intel new strategy to slow down devices to save energy and decrease produced heat?
Any idea from experienced programmers here?

Hi @Tom,

My first thought on this is some sort of multi-core interaction causing both Cantabile and Keyscape to compete for CPU cores.


  1. disabling Cantabile’s multi-core support (Options -> Audio Engine -> Number of Audio Threads -> 1 and see if that makes a difference).
  2. playing with Cantabile’s thread affinity settings
  3. disabling hyper-threading (generally a BIOS setting)
  4. running the profiler (View -> Profiler) and check if the load spikes are actually occurring in the processing of the plugin and not somewhere in Cantabile.

Let us know how you go with the above.


Hi @brad - it’s certainly (indeed) a multi-core interaction causing both Cantabile and Keyscape to compete for CPU cores. Keyscape solo (running as app, not plugin) does fine and I get extremely low latencies.

Couple of things:

  • I ran the profiler - it’s Keyscape that runs over 100% - not Cantabile.
  • I played with Cantabile’s thread affinity - no difference.
  • I played with number of audio threads - no difference. BUT I did not go down as low as 1 - I will try that today.
  • I’ll try and disable hyperthreading.

I’ll ping back when I know more.

I also found something else that is strange, and I see it on both systems (my old one that works fine and the new one that doesn’t). Here’s the story:

  • I have a piano rack, with 8-ish different pianos, including 3 Keyscape instances. Those are on different midi channels.
  • Which piano is in use depends on a state - and the state enables/disables the midi channel used.
  • So really, when I play piano, I would expect only 1 Keyscape instance to use cpu. Because only 1 midi channel is active.
  • BUT - all 3 do!!! even though only 1 is really playing.
  • I noticed because on my misbehaving system, those 3 instances go RED.
  • I checked my well-behaving system, and I see the same there (be it that none of the Keyscapes get to the red line - but they all use CPU if I hit the keyboard, even though only one receives midi).

Instead of making MIDI channels active, maybe try to enable/disable the instances you need or do not need for each state. That should lower CPU usage.
Just a thought.

Excellent idea, I’ll try that tonight! Not sure I can do that with the states being set in the song level, and the instances living in a linked rack …

You should be able to set “Enable” by state regardless.

Just guessing, but I wonder if this is just a display quirk where all 3 instances are reporting load from a shared audio processing engine. If you compare the three instances in the profiler are they all burning time?

Yes, they are! And all more or less the same %; and when one goes over 100% they all do.

That’s very strange.

If you’re sure only one is synthesizing sound, but they’re all consuming load then I’d be getting in touch with Spectrasonics about it.

fwiw: I have seen multiple instance issues with this plugin before where the second instance doesn’t load sounds correctly if the first instance is unloaded at the same time (or something like that) so it wouldn’t surprise me if something isn’t quite right here.

A couple of updates …

@Jtoth : tx for that tip. When I disable plugin instances that are not supposed to produce sound it does save significant CPU!
@brad : that said, I tried the following, all to no effect: tell Cantabile to use only 1 core, tell windows to use less cores (advanced boot option).

As far as I can see it’s only Keyscape that misbehaves. I have other instances (Kontakt, Arturia Piano V, various effects) running and those hardly consume CPU (which makes sense on such a fast system). I’m in touch with Keyscape but since I can only reproduce the issue in a cantabile rack they are blaming it on contabile (of course)

All this just confirms my decision to stay the h*** away from Spectrasonics plugins for live use. Eric Persing and the team seem to have no respect for PC resources at all :wink: - his stuff sounds super-sweet, but all his plugins are resource hogs…


OK, I did some more experimenting. It’s definitely Keyscape misbehaving, not Cantabile. All other plugins perform fine. Keyscape even misbehaves when there is only one instance, in one song (and no setlist loaded).

Seems like a pattern (like @brad mentioned) - I can find plenty complaints about keyscape here - even one of mine:

1 Like

Did you try to play Keyscape instruments from Omnisphere interface? The Keyscape plug is a simplified version of the Omnisphere one, both sounds the same. Just a though.

Totally agree.

@cpaolo : I don’t have Omnisphere.
@Torsten : my conclusion too now :frowning:

I have a couple of good Yamaha C7 from Synthogy (Ivory II Grand) and N.I. (Noire). Same for Rhodes, Clavinet, Wurli, included in many bundles. I don’t interested in “toy keyboards”, so I never bought Keyscape. Anyway, one of my Spectrasonics-addicted friend, usually play Keyscape from Omnisphere GUI. That’s why I told you about this way to play Keyscape without… Keyscape


@Torsten and I have always agreed about low cpu footprint vsts for live use in Cantabile. I built my setlists on that idea, mainly because I was using an older laptop, and the sounds used for most gigs doesn’t have to be pristine. I tried larger “sampled” libraries live, but it made no difference between the two on stage.
When using inears, it made some difference, but only on the inears, not the audience sound. That said, I now have better computers, and tried Keyscape inside of Omnisphere live, and had no problem with CPU, even with other vsts loaded. I still find the audience sound the same. Large gigs, and recordings would be the best usage of Spectrasonics, where things are well controlled, and sound systems are obliging. It has been my experience, and perception, that Keyscape runs smoother in Omnisphere, than alone.


For me, no better electric piano’s than the Keyscape ones. I use them live all the time (pre-Covid…). For acoustic pianos I prefer Pianoteq. The trick with Keyscape - at least for me - is stay away from layered patches (the DUO’s in Keyscape), as both Omnisphere and Keyscape do not make use of multi-core engines. For those you better use two seperate instances of Keyscape or Omnisphere. I notice no differences in either using Keyscape or Keyscape within Omnisphere. What also helps, is reducing polyphony where possible (I often reduce to 16 voices, and make modifed factory presets accordingly). Then, the CPU load is ok with me, not worse than many other nice VSTs such as Dune, Diva, Zebra…