Auxhost runs after Cantabile closes

When Cantabile loads some of the VSTs apparently load auxhost. When Cantabile closes, each instance of auxhost is still running. Each subsequent load of Cantabile adds new instances of auxhost so that there could be 15 or more instances running which eventually causes Cantabile to crash on load. The Cantabile task and process then needs to be forcibly shut down through Task Manager and each auxhost process needs to be terminated as well (boring) as well to get things going again. Any ideas on this?

Could this be related? I can confirm that this behavior started with me on build 3179.

I can confirm that the auxhost issue is also related. I reverted to 3176 and the problem disappeared.

Hi @soundassets

That’s interesting - I’ll check this out. Auxhost is part of jBridge but perhaps there’s a reproducible issue there I can resolve.

I’ve logged it for now but in the meantime in the later builds the “Flush Tail Sounds” option is disabled by default so this issue shouldn’t happen (unless you turn on this option).


Confirmed 3188 is fine. Auxhosts are terminated upon C3 exit. I haven’t touched flush tails so I can’t comment if turning on or off will recreate the issue.

Started again with 3188 and also 3189. Seemed to work for a day or so. I did not suspend or replace any plugins because that was a sure way to have problems. Cantabile began crashing on load. Sometimes I could open a blank and load the project no problem but it would crash on exit leaving a second instance of Cantabile running behind the scenes (task manager). Funny that I could load it manually when it would crash if Cantabile started up with it. Even so Cantabile would crash on exit with the second instance running. I even eliminated all auxhost plugs to see but the same thing exists. I went back to 3176 again and it’s back to stable so far.

Hi @soundassets

How weird - I was testing this yesterday and couldn’t reproduce any issues, even with flush tail sounds turned on. Does it make a difference which plugin you’re loading via jBridge?


Brad, thanks for the email help. Lightning fast as usual :slightly_smiling:.
You were correct, this problem and a host of others that cropped up, were caused by the GSI VB-3 64bit VST. I replaced it with the 32 bit VST as you suggested and I am back on 3189 with no issues! :smile:.