Aargh! Where is my recording?


#22

try a search for “recording-in-progress*” ?


#23

No, nothing remotely like that name to be found.


#24

Search your whole hard drive for *.WAV and a file size of no less than, what, 1.2Gb? A 130 minute file should actually be biger than that at 10.9 Mb a minute or whatever it is. Check out any big a$$ file you find. Or maybe it’s in some kind of TEMP file form- might want to search any large file.


#25

I already suggested that (above) :wink: he said he had


#26

G-drive has some recover files utilities. If you go to another computer and logon to Google accounts then open drive and point to the directory in question, is there anything there besides the Jason file?

Maybe look around for recovery options?


#27

I’m saying it may not show up as a WAV though- there could be a mirror of it as an undefined temp file, so search for any unusual large file.


#28

Yikes, sorry to hear abou tthis. I don’t have an immediate answer for this, but some comments on how it works that might help:

  • While the file is being recorded, it doesn’t have an extension of .wav. Instead it’ll be named `recording-in-progress-9999999999.tmp" where 9999999999 is some number. If your machine is set to hide .tmp files it might not be showing up in explorer.
  • If it’s a long recording, Cantabile may have saved it as a wave64 file… look for w64 file extensions too.
  • The fact the file the appears in Cantabile’s recording list however suggests it got past the point or renaming the “recording-in-progress” to it’s actual final name and should have it’s correct .wav or .w64 file name

Other than that, I can’t think of how the file could have been in-advertantly deleted by Cantabile. My guess is it’s either:

  • in another folder somewhere (I noticed you’ve got the selected plugin name in the recording folder path… I wonder if that’s confusing things)
  • it’s under another name (eg: different extension that’s being hidden by explorer)
  • it never got recorded in the first place for some reason. That’d be a bug but I’ve not had another other reports of issues like this. Have you tried making a test recording with your current settings to make sure it’s recording correctly?
  • some kind of file system corruption. (run a check disk)

Finally, if you do manage to locate the recording-in-progress, I’ve got a tool that can recovery that to a working wave file if you need it.

Brad


#29

Thanks for all the ideas, guys. I’ve done a few searches based on size, location and file names, but so far nothing. I’ve run out of battery power now, so I need to unload the van and get hold of a power supply before I can do anything more.

As soon as I can I’ll report back.


#30


#31


#32

I’ve not named the recording with a plug-in name; it just happens to be the name of the first song in the set ‘E3 2Tron’ - where I pressed the ‘record’ button.


#33

Running chkdsk now…

At this point I’m very nervous about running a test recording in case there’s ANY chance of recovering this recording and making a test scuppers that chance? @brad

Ah, I see what you mean about the plugin name in the naming box. Damn! How did that get in there? I didn’t set it like that deliberately. Do you think that could have something to do with this? The name it has actually allocated doesn’t show a plug-in name…


#34


#35

I just ran a recording test on my backup laptop using the same filename concatenation - it worked fine.

Ah! I then tried recording to Google Drive and got an exact recreation of the problem: json file created, but no wav files. I think I’ve found the smoking gun. I thought recording to a Cloud drive was a good option, since it would backup behind the scenes - best laid plans. Sigh…

If recording to a Cloud drive doesn’t work I’d say it needs to be prohibited in a future version of Cantabile.


#36

Can anyone please confirm my findings? Try using a Google Drive folder for the recording location and see what happens.


#37

Just a shot in the dark:
Maybe the google drive directory is observed by a google windows service (running in background) which tries to synchronize this directory to the cloud in a certain time interval. Then it could be possible that this service somehow failed and deleted the file.
So my suggestion is: Install “Recuva” (NOT to the C drive, but to an external USB drive). Start scanning for deleted files (deep mode). You can then sort the result list by file size (or extension). Maybe you’ll then find your desired files there. Then there would be the chance of recovering them.


#38

Thanks for the thought.

In actual fact Google is not installed on this machine - the remaining folder is just a hangover from when it was!

(which means my idea of it backing up automatically was flawed anyway)


#39

Interesting. I’ll have to check that out… I’m guessing some sort of file sharing issue between google cloud service and Cantabile is spooking one or or the other. Either Google is deleting the file, or Cantabile is failing to create it.

So you see the recording-in-progress file while the recording is happening?

Another thought. Once the recording finishes, Cantabile renames the recording-in-progress file. Perhaps that’s freaking out google?


#40

As I said, Google isn’t even installed on this machine. I thought it was, but it isn’t - I had uninstalled it.

I had left the Cantabile recording location set to that folder, but it’s just a folder.

So, no, I don’t think Google software is involved in this.

I’m still loathe to start trying anything out on this machine until I’m sure (though I’m getting the idea that it’s a done deal…) the recording is utterly lost. So I don’t want to be running test recordings, or trying anything else. With this in mind I can’t tell you what is happening during recording, or anything else. I’m not touching it until the game is up!

I’ll try a test on my backup machine…


#41

The results from my backup machine…

When I first tried to record to the Google Drive folder yesterday I just got a json file and nothing else - exactly the same as my main machine. Now when I try recording again I can see the ‘recording’ file and I get a wav file at the end of the process. In other words, the problem has gone away.

Can there be something happening the first time a recording location is used?

I created a new folder ‘Recordings2’ and set Cantabile to this new folder. I tried to record… Red light on, seems to be working, but no wav file created. I tried a second time - wav file created.

I’ve tried again a few more times, but now I get a wav file every time.